4 votos

Vagabundo con VMware ESXi proveedor

Estoy intentando trabajar con Vagrant y el vagabundo-vsphere plugin para implementar máquinas a mi VMware ESXi server. Alguien ha tenido suerte en conseguir que esto funcione? Me doy cuenta de que vagrant-vsphere es todavía la versión 0.0.1 y aunque seguramente habrá errores.

Specifially, Vagrant y vagrant-vsphere aparece un error durante la vsphere conexión, sin embargo, SSH y CLI está habilitado el acceso y la vSphere powershell es capaz de conectarse sin problema.

INFO alcaide: Llamar a la acción: #
ERROR alcaide: Error: VagrantPlugins::VSphere::Errores::VSphereError

El hostd archivo de registro en el servidor ESXi muestra el Vagrant haciendo un SearchIndex consulta.

1voto

Henk Puntos 1107

En el momento, le no fue incluido, pero ahora es en vagabundo 1.3.5 (15 de octubre de 2013).
De la lista de cambios: ESXi es ahora un invitado compatible OS. [GH-2347]

1voto

Djidiouf Puntos 71

Está disponible con un plugin.

Lista de plugins de vagabundo están allí: https://github.com/mitchellh/vagrant/wiki/Available-Vagrant-Plugins

Y allí, es el plugin para vagabundo con vsphere como proveedor: https://github.com/nsidc/vagrant-vsphere/ . Se soporta la última versión de fecha de vagabundo 1.6.3.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: