6 votos

Ubuntu 14.04: Ve a mi PC la red inalámbrica, pero ganó ' t Conecte a ella, sigue pidiendo la contraseña de WPA

Especificaciones:

Equipo:

Sony Vaio VGN-NW240F

Tarjeta Wifi:

Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

Más información (lspci -vv -s):

Subsystem: Foxconn International, Inc. T77H126.00 802.11bgn Wireless Half-size Mini PCIe Card
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 17
Region 0: Memory at d2500000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: ath9k

Y aún más (modinfo ath9k)

filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
license:        Dual BSD/GPL
description:    Support for Atheros 802.11n wireless LAN cards.
author:         Atheros Communications
srcversion:     BAF225EEB618908380B28DA
alias:          platform:qca955x_wmac
alias:          platform:ar934x_wmac
alias:          platform:ar933x_wmac
alias:          platform:ath9k
alias:          pci:v0000168Cd00000036sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000036sv0000185Fsd00003027bc*sc*i*
[alias...]
depends:        ath9k_hw,mac80211,ath9k_common,cfg80211,ath
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        00:A5:A6:57:59:DE:47:4B:C5:C4:31:20:88:0C:1B:94:A5:39:F4:31
sig_hashalgo:   sha512
parm:           debug:Debugging mask (uint)
parm:           nohwcrypt:Disable hardware encryption (int)
parm:           blink:Enable LED blink on activity (int)
parm:           btcoex_enable:Enable wifi-BT coexistence (int)
parm:           bt_ant_diversity:Enable WLAN/BT RX antenna diversity (int)
parm:           ps_enable:Enable WLAN PowerSave (int)

Mi red funciona perfectamente bien con este equipo en windows 7, y con varios otros equipos y dispositivos. He instalado Ubuntu 14.04 hoy, y funciona perfectamente ,excepto por el wifi.

Cuando intento conectar (icono de wifi, name_of_network), una ventana pidiendo la contraseña va apareciendo cada minuto o así, y no se conecta. La contraseña es correcta.

Traté de borrar la red de la conexión de la lista (icono de wifi, editar conexiones), reinicie mi pc y vuelve a intentarlo, sin éxito.

Ethernet funciona a la perfección.

Tengo que asumir que es relativa a la de Ubuntu, ya que la tarjeta inalámbrica es reconocido y puede escanear las redes disponibles.

$ rfkill list
0: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Yo soy de la idea y no sabes la arquitectura de Ubuntu 14.04 lo suficientemente bien como para intentar cualquier cosa.

¿Usted tiene sugerencias?

10voto

William Abma Puntos 66

Por lo tanto, mi problema fue arreglado. No estoy muy seguro cómo, pero aquí es lo que hice:

sudo service network-manager restart

Tal vez que ayudará a otros que tienen este problema, si era la solución por supuesto.

2voto

ja_him Puntos 11

Por favor, disculpe la falta de formalidad en esta respuesta, sólo un rápido aviso a los demás para que lo único que trabajó para mí después de horas de buscar y probar diferentes cosas.

Pasé las edades tratando de conseguir algo de trabajo - en la final se hizo evidente que, en realidad, la tarjeta de red en sí trabajó (porque no estuvo fino en otro sistema operativo); que la red wifi trabajado (porque podía sentarse allí en mi teléfono utilizando sólo fine); que la contraseña era correcta; y que me podía conectar a internet a través de mi conexión por cable.

El problema resultó para mí fue que la tarjeta de red que tengo es un poco... no se que impresionante.

Primero me enteré de que aquí lo que mi tarjeta de red se

sudo lshw -class network

(Es una Realtek RTL8821AE 802.11 ac PCIe del Adaptador de Red Inalámbrica, por lo que he usado "RTL8821AE" en mis búsquedas)

Luego he buscado el driver y me tomó un tiempo, pero finalmente he encontrado este hilo que dijo que había un nuevo... voy a decir del conductor (?!) ... y seguí las instrucciones. Fue sólo a través de github enlace que realmente podría trabajar donde el ... que voy a decir del conductor (?!) ... y fue descargado en mi ordenador portátil, descomprimido y copiado en una memoria USB. Luego me hizo el hacer comandos etc. Boom! funcionó :)

Y yo también tuve que usar este comando a veces para borrar cache o lo que sea:

sudo service network-manager restart

0voto

Tatakai Wasumi Puntos 393

Si alguien más está teniendo el mismo problema que yo, donde usted tiene que ejecutar sudo service network-manager restart cada vez que inicio de sesión para su wifi para trabajar. He encontrado una solución permanente para mi adaptador de red, la nueva versión de ubuntu se rompió. Ignorar mis comentarios anteriores acerca de la degradación del núcleo como el principal problema era el nuevo paquete wpasupplicant en 14.04.

Mi solución consistió en obtener este ppa: deb http://ppa.launchpad.net/mathieu-tl/nm/ubuntu saucy main tiene Ubuntu 13.10 gerente de la red de paquete y paquete wpasupplicant. Fui a sináptica y bajó sólo el paquete wpasupplicant. Nunca tengo que ejecutar el comando sudo service network-manager restart de nuevo.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: