2 votos

No se reconoce el micrófono de los auriculares de Ubuntu 16.04

Por lo tanto, mi portátil no reconoce correctamente mis auriculares.

Llevo un par de días trasteando con ello y he probado varias soluciones online, ninguna me funciona.

Problema: La toma de auriculares no reconoce mis auriculares y mi micrófono por sí solos. Puedo cambiar manualmente el canal de salida para que al menos pueda sacar algo de sonido de la toma. Pero el micrófono no funciona y no se reconoce. Aunque el sonido funciona después de cambiarlo manualmente, sigue apareciendo como "desconectado". No consigo que el micrófono funcione. El micrófono interno tampoco funciona. El micrófono interno pretende obtener algo de sonido, pero tampoco puedo grabar ni transmitir nada.

He jugado con alsamixer. No se ha silenciado nada, he cambiado la configuración por todas partes sin ningún cambio real. He instalado pavucontrol, pulseaudio, audacity (para los códecs), actualizado dkms, y el sonido no mejoró - de hecho, tengo menos canales para usar, la mayoría de los cuales no funcionan, en ciertos ajustes no obtuve ningún sonido, ni siquiera de los altavoces internos. Algunos ajustes eran simplemente terriblemente bajos. Reinstalé ubuntu-desktop varias veces. Nada parece funcionar. También he intentado cambiar algunos detalles en los archivos .conf, pero no cambiaron el sonido ni un poco. También eché un vistazo a hdajackretask. Aunque no estoy muy seguro de sus detalles.

Probé los auriculares USB de un amigo y funcionan perfectamente, por lo que pude comprobar.

Mi tarjeta es la HDA Intel PCH, mi controlador es el Realtek ALC 256. El portátil es un ASUS X555U con Skylake. Ubuntu 16.04.

¿Qué más puedo hacer? Me parece bien cambiar el canal de los auriculares manualmente, pero que el micrófono no funcione es un poco molesto.

Edit: Si te sirve de ayuda, aquí tienes la información de alsa: http://www.alsa-project.org/db/?f=c6ef73aae969f1da4347154e2977d49711a81e78

Edición: He arreglado la detección de los auriculares añadiendo el modelo adecuado a /etc/modprobe.d/alsa-base.conf en mi caso que era options snd-hda-intel model=headset-mode o options snd-hda-intel model=headset-mic (ambos funcionan bien). Ahora cambia entre los altavoces y los auriculares al conectar y desconectar automáticamente.

Sin embargo, ni el micrófono interno ni el de los auriculares funcionan.

Edit2: Hay una solución para esto, sólo funciona hasta el reinicio: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1596381 Parece que están en ello y como esto es suficiente para mí, diría que esto está resuelto.

0voto

MSchu Puntos 36

Hay una solución para el Asus X555U con el lugar Realtek ALC256 para esto, sólo funciona hasta el reinicio.

sudo hda-verb /dev/snd/hwC0D0 0x1a SET_AMP_GAIN_MUTE 0x5003
sudo hda-verb /dev/snd/hwC0D0 0x1a SET_AMP_GAIN_MUTE 0x6003
sudo hda-verb /dev/snd/hwC0D0 0x23 SET_AMP_GAIN_MUTE 0x5200
sudo hda-verb /dev/snd/hwC0D0 0x23 SET_AMP_GAIN_MUTE 0x6200
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_AMP_GAIN_MUTE 0x503f
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_AMP_GAIN_MUTE 0x603f
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_POWER_STATE 0
sudo hda-verb /dev/snd/hwC0D0 0x1a SET_POWER_STATE 0

Consulte aquí para saber más: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1596381

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: