1 votos

Corregir el protocolo para solicitar una actualización de un paquete de buggy en ubuntu 14.04 LTS

Estoy usando Ubuntu 14.04.5 y durante mucho tiempo no ha sido un problema menor con emacs y diccionarios comunes. En resumen, la versión de los diccionarios comunes en las que se incluye con Ubuntu 14.04.5 se diccionarios comunes 1.20.5, y cuando la versión de emacs que se incluye con Ubuntu 14.04.5 se inicia, se genera un error en el emacs archivo de mensajes:

Error while loading 50dictionaries-common: Symbol's value as variable is void: debian-aspell-only-dictionary-alist

Este es un error conocido en los diccionarios comunes 1.20.5. Sin embargo, este error fue corregido hace un tiempo, por ejemplo, en los diccionarios comunes 1.22.6 .

Yo (tal vez ingenuamente) sospecha que la actualización de los diccionarios comunes a una más reciente versión estable sería una forma relativamente sencilla de hacer que el problema desaparezca. Sin embargo, si he entendido correctamente, la versión de los diccionarios comunes en backports es todavía 1.20.5:

$ sudo apt-get install -t trusty-backports dictionaries-common

informes

dictionaries-common is already the newest version.

Si quiero arreglar este problema, sin actualizar mi versión de Ubuntu, ¿cuáles son mis opciones? Siento que de alguna manera debe informar de ello a los desarrolladores de Ubuntu, porque esto es una (muy baja prioridad) error en un establo versión LTS de ubuntu, lo que no se menciona (por lo que puedo ver) en espera de SRUs así que en un mundo ideal me gustaría de alguna manera dar a conocer el problema y sería fijo. Por otro lado, al final del día me imagino que un paquete de diccionarios es muy poco probable que romper otros paquetes (famosas últimas palabras), y tal vez yo debería tomar el toro por los cuernos y actualización de los diccionarios comunes a 1.22.6 o más tarde por mí mismo. Sin embargo, yo no sé cómo hacer esto y además no sé si es prudente comportamiento. He descargado un tar.gz archivo de Launchpad y yo podría seguir adelante y trate de compilar e instalar, pero me preocupa que me gustaría, a continuación, en realidad se estaría violando el gestor de paquetes del sistema completo. Es que esto no se recomienda? Cómo se debe proceder en este tipo de situación?

1voto

John Smith Puntos 16

Muchas gracias a muru para el fomento de mí no sólo para compilar el código fuente, pero para hacer un paquete. Mi comprensión de la situación es que la creación de un paquete desde el origen resuelve el problema que me preocupaba (rompiendo el sistema de paquetes) porque (creo) la idea es que todas las dependencias necesito son tratados por el sistema.

Aquí es exactamente lo que me hicieron en mi caso. Así como la descarga de dictionaries-common_1.22.6.tar.gz de launchpad también he descargado el archivo dsc dictionaries-common_1.22.6.dsc, como muru sugerido. He seguido las instrucciones de aquí:

http://blog.riamaria.com/99/what-to-do-with-a-dsc-file-dpkg/

Más precisamente, el plan es hacer un paquete de debian

dictionaries-common_1.22.6_all.deb

y, a continuación, instalar esto en mi sistema.

Antes de empezar he tenido que instalar dpkg-dev así que puedo hacer paquetes.

Entonces me corrió

dpkg-source -x dictionaries-common_1.22.6.dsc 

y esto crea un nuevo directorio dictionaries-common-1.22.6 que me de cd ed en. Dentro de este directorio traté de

dpkg-buildpackage -rfakeroot -b

pero la primera vez que me encontré con este comando se produjo el error

dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 7) quilt (>= 0.40) docbook-dsssl jade w3m slice recode
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting

Lo que ocurre aquí es que necesito instalar algunos paquetes más en mi sistema con el fin de construir diccionarios comunes. Lo he instalado estos paquetes usando apt-get y luego lo intentó de nuevo. Por supuesto, esto no está garantizado para trabajar -- tal vez el defecto de las versiones de estos paquetes en 14.04 no sería suficiente. Pero tuve la suerte-que estaban. La segunda vez que he probado el dpkg-buildpackage comando fue un éxito. Yo era incapaz de firmar el paquete como el mantenedor del paquete, como era de esperar, porque yo no soy el mantenedor del paquete y no sé el mantenedor del paquete de la clave secreta. Pero no creo que esto me molesta.

El resultado fue que ahora, de vuelta en el directorio donde estaba haciendo todo esto, yo tenía un nuevo archivo

dictionaries-common_1.22.6_all.deb

que se me ha instalado correctamente con

$ sudo dpkg -i dictionaries-common_1.22.6_all.deb

Mi error en emacs se ha ido!

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by:

X