18 votos

Archivos en /etc/network/interfaces.d ignorados, pero no / etc / network / interfaces en sí

Para Ubuntu 16.04 LTS (GNU/Linux 3.10.96-113 armv7l)

Cuando tengo el siguiente, mi configuración estática es ignorado:

/etc/network/interfaces

source-directory /etc/network/interfaces.d

/etc/network/interfaces.d/eth0

auto eth0
iface eth0 inet static
        address 192.168.40.112
        netmask 255.255.255.0
        gateway 192.168.40.1
        dns-nameservers 8.8.8.8

Sin embargo, con los siguientes:

/etc/network/interfaces

auto eth0
iface eth0 inet static
        address 192.168.40.112
        netmask 255.255.255.0
        gateway 192.168.40.1
        dns-nameservers 8.8.8.8

source-directory /etc/network/interfaces.d

la configuración estática se establece en el arranque (independientemente de lo que tengo en las interfaces.d/).

En caso de que sea pertinente, estoy usando una regla de udev para cambiar el nombre de la interfaz eth0 (que solía ser "enx001e063110c0"...)

26voto

Chris Puntos 12438

Creo que lo encontré Del manual , el problema parece ser la palabra clave source-directory . Parece que, desde 16.04, ya no es compatible.

Entonces reemplazando

 source-directory /etc/network/interfaces.d
 

con

 source /etc/network/interfaces.d/*
 

parece arreglar el problema

2voto

WinEunuuchs2Unix Puntos 1032

El Kernel 3.10 es demasiado viejo para systemd

De acuerdo a systemd requisitos del kernel en github en (github.com - systemd LÉAME) que necesita la versión >= 3.12:

REQUIREMENTS:
        Linux kernel >= 3.12
        Linux kernel >= 4.2 for unified cgroup hierarchy support

Las líneas 37, 38 y 39 se imprimen por encima.

Se ejecuta bajo el BRAZO de la arquitectura que yo, francamente, saben muy poco acerca de. La búsqueda de Google me dice que su armvl7 es utilizado por la Raspberry Pi es un kernel de 32 bits.

La actualización de su Núcleo a los tiempos modernos

Si desea que el último (el21 de octubre de 2016) "Sucio de la VACA" de la protección de seguridad (¿Qué es "Sucio VACA" error y Cómo puedo proteger contra ese error?) además de un sinfín de otros parches de seguridad, correcciones de errores y mejoras en el sistema (después de que su versión de 2013) debe estar en el núcleo 4.4.0-47.

Lamentablemente no sé cómo hacer para que una RaspberryPi. He enlazado esta pregunta a las personas que usan RaspberryPi y les hemos pedido que la crítica a esta respuesta.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: