32 votos

Ubuntu 18.04 no se puede instalar Viber

Estoy tratando de conseguir Viber en mi nuevo Ubuntu 18.04 pero me da estos errores ...

sudo dpkg -i Downloads/viber.deb 
(Reading database ... 138136 files and directories currently installed.)
Preparing to unpack Downloads/viber.deb ...
Unpacking viber (7.0.0.1035) over (7.0.0.1035) ...
dpkg: dependency problems prevent configuration of viber:
 viber depends on libcurl3; however:
  Package libcurl3 is not installed.

dpkg: error processing package viber (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 viber

76voto

El problema no es sólo con el viber.archivo deb, pero también con la libcurl3 requisito de viber.deb.

En 18.04 libcurl3 no puede coexistir con libcurl4 así que va a enfrentar los problemas con otras aplicaciones. En mi caso, Viber y el Vapor no podían coexistir.

Después de algunas búsquedas he encontrado la siguiente solución, que es depackage, arreglar la situación de dependencia y, a continuación, construir un nuevo viber archivo.

Los pasos son:

  1. Guardar el viber.deb archivo en una carpeta
  2. Abra la carpeta en un terminal
  3. ejecutar los siguientes comandos
  4. dpkg-deb -x viber.deb viber
  5. dpkg-deb --control de viber.deb viber/DEBIAN
  6. Editar viber/DEBIAN/control y repace "libcurl3" con "libcurl4" (también eliminar la última línea en blanco en el archivo o se producirá un error después)
  7. dpkg -b viber viberlibcurl4.deb
  8. sudo dpkg-i viberlibcurl4.deb
  9. O instalar .archivo deb con gdebi

Viber parece que funciona ok con libcurl4 más pequeño para mí hasta ahora.

He encontrado la solución aquí, en un comentario...

https://linuxconfig.org/how-to-install-viber-on-ubuntu-18-04-bionic-beaver-linux

8voto

user254511 Puntos 61

La forma más fácil es convertir el paquete rpm en Viber sitio web para un paquete deb. Para hacerlo:

Descargar el paquete rpm con:

wget https://download.cdn.viber.com/desktop/Linux/viber.rpm

Instalar alien, convertir el paquete rpm y instalar la recién creada paquete deb:

sudo apt-get install alien
sudo alien --to-deb --scripts viber.rpm
sudo dpkg -i viber_7.0.0.1035-3_amd64.deb

La conversión será de unos 5 minutos. Ser paciente!

3voto

Puck Puntos 1

La solución de instalar Viber en Ubuntu 18.04 es incluir de manera explícita la libcurl3 paquete de requisitos previos como parte de la apt de comandos de instalación:

sudo apt install libcurl3 ~/Downloads/viber.deb

Cómo instalar Viber en Ubuntu 18.04 Bionic Beaver Linux

También puede instalar el flatpak versión de flathub.org

0voto

Brood Puntos 179

Usted podría tratar de solucionar dependencias rotas con el siguiente comando:

sudo apt-get install -f

Después de que intente de nuevo instalar Viber con el comando que se utiliza:

sudo dpkg -i Downloads/viber.deb 

0voto

Mark Puntos 1

La mejor forma de instalar solo deb-paquetes a utilizar APT-herramienta, que va a resolver todas las dependencias de forma automática:

sudo apt-get install ./Downloads/viber.deb 

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: