4 votos

Cisco IOS XR versión aclaración

Me he encontrado a través de esta cisco asesor

Dice:

Este error se introdujo en IOS de Cisco XR versión de Software 3.6.2 y se fija con SMU hfr-k9sec-3.6.2.CSCtd74795. El SMU ID para esta revisión en 3.6.2 es AA03656. Esta vulnerabilidad ha sido fijo en 3.8.3, 3.9.1, y 4.0.0 para los clientes que ejecutan posterior del software las versiones. El Software de la versión 3.7 no es afectados por esta vulnerabilidad.

Estoy tratando de averiguar algo, de acuerdo a esto, 3.6.2 es vulnerable a menos que se fija con el mencionado SMU.

¿Qué acerca de las versiones tales como:

  • 3.6.1
  • 3.6.0
  • 3.5.4 y antes... son también vulnerables?

También, se dice que se fija en 3.8.3 y 3.9.1, ¿por qué no hacer también mención 3.9.1, no es 3.9.1 > 3.8.3 por lo que su obvio que también se fija en 3.9.1?

2voto

Mike Pennington Puntos 6056

Usted está pidiendo una pregunta razonable. La primera cosa a entender es que Cisco de desarrollo de software a menudo sucede en ramas paralelas1, con respecto a donde las funciones están comprometidos.

En este caso, un desarrollador al mismo tiempo comprometidos código vulnerable en 3.6.2 y 3.7.1; que el código vulnerable escapó Q/A de pruebas y fue lanzado en CCO. Todo el software liberado en las ramas después de2 3.6.2 y 3.7.1 era vulnerable3 hasta que la solución se ha comprometido de forma simultánea en 3.8.3, 3.9.1 y 4.0.0


FINAL DE NOTAS:

  1. Ver a Jeff Atwood el blog de Codificación de Horror: el Software de Ramificación y Paralelo Universos
  2. Versiones 3.5.4, 3.6.0, 3.6.1 no debe ser vulnerables ya que no fueron mencionados en la notificación
  3. Versiones 3.8.0, 3.8.1, 3.8.2, y 3.9.0 también contienen el código vulnerable

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: