1 votos

GnuPG-2.2.10 gpg: Fatal: libgcrypt es demasiado viejo (necesita 1.7.0, tienen 1.6.5)

Estoy tratando de instalar gnupg a partir de código fuente utilizando el siguiente método:

paso 1:

Yo cd sin comprimir gunpg-2.2.10

cd Downloads/gnupg-2.2.10

paso 2:

Puedo ejecutar el comando :

./configure

paso 3:

Puedo ejecutar el comando

make

también he instalado el libgcrypt como antes de seguir los pasos anteriores como sigue:

paso 1:

I cd a la libgcrypt carpeta sin comprimir

paso 2:

Puedo ejecutar

sudo ./configure

paso 3:

Puedo ejecutar :

sudo make

paso 4:

Puedo ejecutar

sudo make install

pero cada vez que voy a la carpeta de gnupg-2.2.10/g10 y ejecutar

./gpg

Puedo conseguir

 gpg: Fatal: libgcrypt is too old (need 1.7.0, have 1.6.5)

ahora aquí está la salida de ls /usr/local/lib

libassuan.la        libgcrypt.so.20         libksba.la         libnpth.so.0
libassuan.so        libgcrypt.so.20.2.3     libksba.so         libnpth.so.0.1.2
libassuan.so.0      libgpg-error.la         libksba.so.8       python2.7
libassuan.so.0.8.1  libgpg-error.so         libksba.so.8.11.6  python3.5
libgcrypt.la        libgpg-error.so.0       libnpth.la
libgcrypt.so        libgpg-error.so.0.24.3  libnpth.so

por favor, dime ¿cuáles son los comandos para corregir este error? y por favor, nota que yo no soy experto en linux

1voto

mi076 Puntos 11
<p>Tratar de</p> <p>Export LD_LIBRARY_PATH = / usr/local/lib: $LD_LIBRARY_PATH</p> <p>. / gpg</p>

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: