17 votos

La conexión RDP con Windows 7 se mantiene muy lenta

Tengo un problema con la conexión a Windows 7 a través de RDP. Puedo abrir una sesión RDP, pero independientemente de la configuración, los tiempos de respuesta son muy largos. Este es el caso en particular cuando se abre una página web en un navegador. He probado IE, Firefox y Google Chrome.

También uso la conexión RDP a un servidor de Windows 2008 desde la misma máquina cliente, y la velocidad es muy normal con todas las funciones activadas. Tenemos Gigabit Ethernet aquí. Así que creo que no puede ser culpa del cliente.

En cuanto a la máquina de Windows 7, he intentado apagar todas las características gráficas y convertir los niveles de color a 256 colores. El resultado es el mismo.

Si trabajo localmente en la máquina, no puedo ver ningún retraso.

¿Qué más he intentado?

  • Usando el viejo cliente RDP 5 de Microsoft
  • Estableciendo el nivel de sintonía automática de la red como se ha visto aquí

¿Tienes alguna idea?

¡Gracias de antemano!

Actualización el problema parece ser con la representación del contenido de la ventana. Todos los bordes de las ventanas y los cristales se renderizan muy rápidamente, pero el contenido se muestra muy lentamente. También los movimientos del ratón son reconocidos por el cuadro de Win 7 sólo después de algún tiempo.

¿Hay alguna configuración oculta en el RDP, donde uno podría desactivar algunas características avanzadas o activar el caché? Yo uso Bitmap Caching, pero esto aparentemente no ayuda.

9voto

Luke Puplett Puntos 487

Tengo el mismo problema. El mío a veces se bloquea por completo y es definitivamente el mismo problema con los contenidos complejos de las ventanas que se dibujan lentamente. Abrir IE a veces lo cuelga por completo.

Prometo volver y publicar una respuesta. ¡Todos los hilos sobre esto en la web están muertos!

NO Arreglar

En mi caso, se trataba de un controlador gráfico malo (por defecto de MS) para el IBM eServer 326m que estoy utilizando. Desde que pasó a Win 2008 necesitaba volver a apuntar al controlador.

En el improbable caso de que su servidor también tenga una ATI ES1000:

http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-5074558&brandind=5000008

*ACTUALIZACIÓN 1

En realidad esto no lo solucionó. El desplazamiento en IE no es una buena prueba. Parece que no le gusta dibujar los snap-ins MMC de Windows 2008 y toda la conexión se cuelga cuando hay demasiados abiertos.

FIX (PROPIO)

HKEY_LOCAL_MACHINE \SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DWORD, DisableTaskOffload. Establece su valor en 1.

¡¡¡¡¡Oh sí!!!!!

0 votos

+.5 por tu compromiso y +.5 por tus problemas para comentar.

0 votos

Si esta solución funciona, recuerde volver a activar la función de escalado de ventanas TCP: netsh interface tcp set global autotuninglevel=normal; netsh interface tcp set global rss=enabled

0 votos

Además, noto que de alguna manera el DisableTaskOffload se restablece a 255 en mi servidor. Sólo Dios sabe qué está haciendo eso.

3voto

n3rd Puntos 3292

Tuve el mismo problema, y descargando e instalando los últimos controladores de la tarjeta de interfaz de red desde el sitio del fabricante se solucionó.

Desactivar la descarga no es aparentemente una "solución", sino encubrir un problema porque se supone que tu conexión remota funciona bien con la descarga activada.

Pero por si acaso tu problema no se soluciona con los últimos drivers, te enlazo todas las páginas que he encontrado sobre el tema.

http://www.windowsreference.com/Windows-vista/slow-network-copy-and-connection-drops-in-Windows-7/

https://ticketing.nforce.com/index.php?/Knowledgebase/Article/View/19/0/fix-slow-remote-desktop-connection

1 votos

Parece que el problema eran los drivers de VMWare y no el RDP o Windows. Lo siento por no proporcionar este detalle. No pensé en ello primero.

2voto

EvilRyry Puntos 419

Cambiar al tema básico del cursor del ratón. Esto me ha ayudado mucho, aunque todavía no se siente tan rápido como en XP.

1voto

Juriy Puntos 133

Intenta ejecutar este comando en la caja de Win7.

netsh interface tcp set global autotuninglevel=disabled

1voto

w0den Puntos 11

Los últimos controladores en el sitio de asrock eran bastante viejos. Encontré controladores en el sitio de Realtek. Después de instalar estos controladores (v. 7.053) el problema desapareció.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: