1 votos

dpkg : error al procesar el paquete (--install)

Soy un poco nuevo terminal de las cosas y necesito tu ayuda. He intentado instalar XArp en mi máquina con dpkg, pero las necesidades de los paquetes, que no sé cómo instalar. Sólo he intentado instalar libwxgtk2.8-0, pero no puede ser encontrado. He aquí lo que dice:

dave@dave-HP-ProDesk-600-G2-SFF:~$ sudo dpkg -i xarp-2.2.2-amd64-ubuntu-10.04.1.deb
(Reading database ... 345629 files and directories currently installed.)
Preparing to unpack xarp-2.2.2-amd64-ubuntu-10.04.1.deb ...
Unpacking xarp (2.2.2) over (2.2.2) ...
dpkg: dependency problems prevent configuration of xarp:
 xarp depends on libwxgtk2.8-0 (>= 2.8); however:
  Package libwxgtk2.8-0 is not installed.
 xarp depends on libxerces-c3.1 (>= 3.1); however:
  Package libxerces-c3.1 is not installed.
 xarp depends on menu; however:
  Package menu is not installed.
 xarp depends on arptables; however:
  Package arptables is not installed.

dpkg: error processing package xarp (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Errors were encountered while processing:
 xarp

Gracias por la ayuda:)

1voto

Mark Puntos 1

Las dependencias de Xarp paquete no están contenidas en 18.04 LTS repositorio, pero podemos obtener e instalar desde 14.04 LTS repositorio manualmente (tenga cuidado, que no recibirá actualizaciones de seguridad) con los pasos a continuación:

wget http://security.ubuntu.com/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.50-1ubuntu2.14.04.3_amd64.deb
sudo apt install ./libpng12-0_1.2.50-1ubuntu2.14.04.3_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/universe/w/wxwidgets2.8/libwxbase2.8-0_2.8.12.1+dfsg-2ubuntu2_amd64.deb
sudo apt install ./libwxbase2.8-0_2.8.12.1+dfsg-2ubuntu2_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/universe/w/wxwidgets2.8/libwxgtk2.8-0_2.8.12.1+dfsg-2ubuntu2_amd64.deb
sudo apt install ./libwxgtk2.8-0_2.8.12.1+dfsg-2ubuntu2_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/universe/x/xerces-c/libxerces-c3.1_3.1.1-5.1+deb8u4build0.14.04.1_amd64.deb
sudo apt install ./libxerces-c3.1_3.1.1-5.1+deb8u4build0.14.04.1_amd64.deb

sudo apt install ./xarp-2.2.2-amd64-ubuntu-10.04.1.deb

y disfrutar de:

$ xarp --version
XArp - Advanced ARP Spoofing Detection
version XArp 2.2.2

0voto

Zack Puntos 627

Tiene dependencias problema. Esto significa que los paquetes que desea instalar manualmente requiere otro de los paquetes para que sean operativos. Pruebe a ejecutar apt install -fatrer dpkg Esto debería solucionar dependencias problema.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: