1 votos

¿Por qué no arranca mi máquina Linux?

En noviembre compré un Librem 15, que es un sistema Linux en el portátil que funciona PureOS. PureOS no es Ubuntu, pero es un Debian-variante que tiene un montón de seguridad/configuración de privacidad activado por defecto, así que es muy similar. Uno de esos configuración de seguridad predeterminada es el Cifrado de Disco, usando un programa llamado LUKS. Así que cada vez que inicio mi laptop, tengo que introducir primero la contraseña de cifrado de disco para que pueda iniciar el arranque. A continuación, se inicia en PureOS y debo introducir mi contraseña de usuario.

Durante los últimos cuatro meses ha funcionado muy bien y generalmente botas muy rápido. Sin embargo, el día de hoy me encontré sudo apt upgrade a actualizar todos los paquetes de software, y ahora me estoy lamentando de que lo que hice. Ya no botas! Al menos no completamente.

Ahora, lo que sucede es esto:

  • Que me lleva de mi disco cifrado de contraseña
  • Se muestra la animación de arranque
  • Pero simplemente cuelga allí

Si me presione Esc para salir de la animación de arranque de la pantalla, voy a ver un montón de mensajes de arranque y, a continuación, esta línea en la parte inferior:

[ ***] En un inicio se ejecuta el trabajo para /dev/mapper/luks-204dc5ca-8fbd-4b02-9833-3661ffd0c0aa (9min 38s / sin límite)

El 9min / 38s es sólo un temporizador que continuamente se cuenta. Pero sigue contando y contando, nunca procedimiento de un pasado que paso para terminar de arrancar en PureOS. No estoy muy seguro de qué hacer en este punto. He intentado pulsando Ctrl+Alt+Supr desde esta pantalla, y un tiempo realmente trabajado; en el reinicio yo era capaz de conseguir. Pero ahora (después de que otro reinicio) estoy atascado en esta pantalla de arranque de nuevo. Y esta vez parece ser que no va a desaparecer.

¿Cómo puedo obtener mi máquina para arrancar?

ACTUALIZACIÓN: Después de un poco más de la excavación, he descubierto un par de detalles más. Parece que mi disco está segmentado en un par de particiones diferentes. Aquí está la salida de lsblk:

NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
loop0                                           7:0    0  91.1M  1 loop  /snap/core/6259
loop1                                           7:1    0  89.5M  1 loop  /snap/core/6130
loop2                                           7:2    0    91M  1 loop  /snap/core/6350
loop3                                           7:3    0     8K  1 loop  /snap/anbox-installer/24
nvme0n1                                       259:0    0 465.8G  0 disk  
├─nvme0n1p1                                   259:1    0   1.1G  0 part  /boot
├─nvme0n1p2                                   259:2    0 447.5G  0 part  
│ └─luks-0a47a276-75cb-4928-8d8f-35a8d78c02ce 254:0    0 447.5G  0 crypt /
└─nvme0n1p3                                   259:3    0  17.1G  0 part  
  └─luks-204dc5ca-8fbd-4b02-9833-3661ffd0c0aa 254:1    0  17.1G  0 crypt [SWAP]

Me di cuenta de que cuando estoy primero le pedirá que introduzca la contraseña de cifrado de disco, a la que hace referencia el UUID de la partición principal, diciendo Please unlock disk luks-0a47a276-75cb-4928-8d8f-35a8d78a02ce. Pero luego, cuando se queda atascado, hace referencia a la UUID de la partición swap. Que sugiere que, para mí, de que está teniendo problemas para descifrar la partición de intercambio.

0voto

QuentinUK Puntos 116

Al final he tenido suerte y fue capaz de arrancar el sistema. Como mencioné en mi actualización de arriba, me di cuenta de dos diferentes Uuid durante el proceso de arranque, así que un poco de investigación reveló que uno de ellos era mi principal / partición, mientras que el otro era de la swap de la partición, y además estaba ahogada en la partición de intercambio.

Terminé la ejecución de los siguientes dos comandos en serie, por la fuerza de desactivar la swap:

sudo swapoff -a
sudo swapon -a

Luego reinicié y no parecen tener más problemas (toco madera). Pero si yo no hubiera llegado a la "suerte" y metido en el sistema operativo para hacer que el análisis (y para desactivar la swap), no estoy seguro de cómo me podría haber solucionado este problema. Así que la única respuesta que tengo de cómo se pueden obtener, al menos, que ahora es orar!

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: