1 votos

apt-get broken después de la actualización de 32 bits a 64 bits

He de actualizar mi de 32 bits hace un par de días a 64 bits sin mucho éxito.

Desde que sucedió a mi apt-get instalador/actualizador está roto y no puedo hacer actualizaciones más o instalar software.

Estoy trabajando en Ubuntu debido a que hemos recibido un ordenador en el trabajo necesitaba trabajar para el Desarrollo Web. Debido a de 32 bits no fuí capaz de obtener cierto tipo de software instalado.

Como cualquier otra buena persona creyente hice pensé que la actualización fue fácil, tan fácil como lo había hecho tantas veces en Windows, pero en realidad no.

Debido a la falta de experiencia con Linux estoy completamente atascado ahora y ahora sé cómo conseguir que esta resuelto.

La ayuda es más que bienvenida.

He seguido esta guía es un anser en el post con 13 gusta o ups. Editado por: mxdsp y aswered por: Asterix : Es posible la "actualización" de una de 32 bits a una de 64 bits de instalación?

El error que estoy recibiendo:

    The dependencies of the following packages could not be installed:

apt-utils: Depends: apt (= 1.2.29ubuntu0.1) but it is not installed
            Depends: libc6 (> = 2.4) but 2.23-0ubuntu10 is installed
            Depends: libgcc1 (> = 1: 3.0) but 1: 6.0.1-0ubuntu1 is installed
            Depends: libstdc ++ 6 (> = 5.2) but 5.4.0-6ubuntu1 ~ 16.04.11 is installed
code: Depends: libnss3 (> = 2: 3.26) but 2: 3.28.4-0ubuntu0.16.04.4 is installed
       Depends: apt but it is not installed
       Depends: libgtk-3-0 (> = 3.10.0) but 3.18.9-1ubuntu3.3 has been installed
ubuntu-minimal: Depends: apt but it is not installed
update-notifier-common: PreDepends: apt (> = 1.1 ~) but it is not installed
                         Depends: python3: any but it is a virtual package
                         Depends: update-manager-core (> = 1: 16.04.6) but 1: 16.04.15 is installed

0voto

neildeadman Puntos 111

Utilice el comando para iniciar una solicitud interactiva de los paquetes que desea conservar o eliminar para resolver el problema de dependencia:

 sudo aptitude full-upgrade
 

Esto pasará por una serie de preguntas que le preguntarán qué paquete debe guardar o eliminar. Tenga en cuenta que no tiene que seleccionar las primeras opciones que se le dan.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: