2 votos

Reparando la instalación del controlador Broken Nvidia Ubuntu 18.04

Tengo una GTX 1070 en mi Ubuntu 18.04 PC. He intentado instalar los drivers de nvidia a través de un runfile usando el comando sudo ./NVIDIA-Linux-x86_64-418.43.run --no-opengl-files --dkms --no-drm , pero no tienen desinstalarlo correctamente así que ahora yo no puedo hacer --uninstall. No puedo reinstalar el runfile. Tratando de hacer, así que me da:

The distribution-provided pre-install script failed!  Are you sure you want to continue?
-Continue Installation
ERROR: The Nouveau kernel driver is currently in use by your system. This driver is incompatible with the NVIDIA driver
-OK
WARNING: One or more modprobe configuration files to disable Nouveau are already present at: /etc/modprobe.d/nvidia-installer-disable-nouveau.conf ...
ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details.

Y en el archivo de registro:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Tue Feb 26 08:56:40 2019
installer version: 410.93

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin

nvidia-installer command line:
    ./nvidia-installer

Unable to load: nvidia-installer ncurses v6 user interface

Using: nvidia-installer ncurses user interface
-> Detected 12 CPUs online; setting concurrency level to 12.
-> Installing NVIDIA driver version 410.93.
-> Running distribution scripts
   executing: '/usr/lib/nvidia/pre-install'...
-> done.

Me parece que no puede instalar los controladores de nvidia usando apt. Tratando de instalar cualquiera de las versiones y ejecución nvidia-smi me da: NVIDIA-SMI ha fallado porque no podía comunicarse con el driver de NVIDIA. Asegúrese de que la última NVIDIA controlador está instalado y en ejecución.

Y tratando de purgar nvidia con sudo apt-get purge nvidia* me da un error:

Purging configuration files for nvidia-compute-utils-390 (390.87-0ubuntu0~gpu18.04.2) ...
Processing triggers for initramfs-tools (0.130ubuntu3.6) ...
update-initramfs: Generating /boot/initrd.img-4.18.0-15-generic
W: Possible missing firmware /lib/firmware/nvidia/gv100/sec2/sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/sec2/image.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/sec2/desc.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/nvdec/scrubber.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/sw_method_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/sw_bundle_init.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/sw_nonctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/sw_ctx.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/gpccs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/gpccs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/gpccs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/gpccs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/fecs_sig.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/fecs_data.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/fecs_inst.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/gr/fecs_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/acr/ucode_unload.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/acr/ucode_load.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/acr/unload_bl.bin for module nouveau
W: Possible missing firmware /lib/firmware/nvidia/gv100/acr/bl.bin for module nouveau

Yo realmente apreciaría si alguien me puede orientar en la fijación de este roto la instalación sin tener que reinstalar Ubuntu.


Edit: he conseguido "completamente" (tan lejos como el registro me dice) se suprimió el runfile instalación, reinstalación y --desinstalar con el runfile. Sin embargo voy a poner todas las líneas "W: Posible falta de firmware /lib/firmware/nvidia/gv100/seg2/sig.bin para el módulo nouveau"

2voto

Rumbles Puntos 149

Trate de hacer de este lugar:

Esto cerrará su Pantalla Gráfica de Administrador (normalmente de Gnome ahora los días) así que si usted está siguiendo estas instrucciones en la máquina que está ejecutando en ellos, hacer una nota de los siguientes pasos:

sudo telinit 3

Esto debería llevar a una tty (una pantalla negra con un símbolo de inicio de sesión), ahora de inicio de sesión como superusuario (introduzca el nombre de usuario y la contraseña de su cuenta), a continuación, ejecute:

sudo su -

Esto eleva a la root, ahora cd al directorio que el de NVIDIA .ejecute el archivo está en:

cd /home/someuser/Download
bash NVIDIA-Linux-x86_64-418.43.run --no-opengl-files --dkms --no-drm

Finalmente, me di cuenta de que había que modificar mi grub por defecto para evitar algunos errores:

vim /etc/default/grub

Busque la línea que comienza:

GRUB_CMDLINE_LINUX_DEFAULT=

Añadir nvidia-drm.modeset=1 (creo tranquilo y salpicaduras son los valores predeterminados), la mina dice:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1"

Ahora actualizar el grub:

update-grub

Finalmente, reinicia

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: