0 votos

Puedo eliminar los paquetes con dependencias incumplidas?

Hola a tod@s,

Soy un usuario novatillo y tengo instalado Ubuntu 18.04. Lo actualicé desde 17.04 y lo tengo instalado en mi máquina desde hace tiempo, pero no lo utilizaba prácticamente. He de decir que va muy bien y no tengo problemas.

El caso es que he utilizado el comando apt-cache unmet para ver las dependencias no satisfechas y me salen un montón. El caso es que no me gusta tener cosas sueltas en la máquina así que he intentado instalar algunas y me dice esto:

Leyendo lista de paquetes... Hecho Creando árbol de dependencias Leyendo la información de estado... Hecho El paquete linux-gcp-tools no está disponible, pero algún otro paquete hace referencia a él. Esto puede significar que el paquete falta, está obsoleto o sólo se encuentra disponible desde alguna otra fuente

Decir que ya he probado con los comandos:

sudo apt-get autoremove

sudo apt-get autoclean

sudo apt-get update

sudo apt-get -f install

sudo apt-get install ubuntu-restricted-extras

Y me dice que todo está bien, que no tiene que instalar ni eliminar nada más.

Mi pregunta es, ¿puedo eliminar todos estos paquetes?. Si un paquete tiene dependencias incumplidas, ¿este puede funcionar? Si no es así, entiendo que todos estos serían inútiles y que podría cargármelos.

Para que os hagáis una idea, estos son algunos de los paquetes:

kde-baseapps-bin:i386 versión 4:16.04.3-0ubuntu1
libghc-gtk-dev:i386 versión 0.14.7-1build2 : openmsx:i386 versión 0.14.0-2 : gobjc-8-multilib-powerpc64-linux-gnu:i386 versión 8.2.0-1ubuntu2~18.04cross1 : gobjc-8-multilib-powerpc64-linux-gnu:i386 versión 8-20180414-1ubuntu2cross1 : node-almond:i386 versión 0.3.3+dfsg-1 : multimedia-recording versión 0.6ubuntu2 : navit:i386 versión 0.5.0+dfsg.1-2build1 : simgrid-java versión 3.18+dfsg-1 : simgrid-java:i386 versión 3.18+dfsg-1 : cpp-8-s390x-linux-gnu:i386 versión 8.2.0-1ubuntu2~18.04cross1 : cpp-8-s390x-linux-gnu:i386 versión 8-20180414-1ubuntu2cross1 : ballz:i386 versión 1.0.3-1build2 : python3-nose-parameterized versión 0.3.4-4 : libpam0g:i386 versión 1.1.8-3.6ubuntu2.18.04.1 : libpam0g:i386 versión 1.1.8-3.6ubuntu2 : openarena-server:i386 versión 0.8.8+dfsg-1 : libopenimageio-dev:i386 versión 1.7.17~dfsg0-1ubuntu2 : cpp-7-powerpc-linux-gnuspe:i386 versión 7.3.0-27ubuntu1~18.04cross1 : cpp-7-powerpc-linux-gnuspe:i386 versión 7.3.0-16ubuntu3cross1 : nslint versión 3.0a2-1.1build1 : nslint:i386 versión 3.0a2-1.1build1 : python-coverage:i386 versión 4.5+dfsg.1-3 : libsofia-sip-ua0:i386 versión 1.12.11+20110422.1-2.1build1 : libghc-twitter-types-dev:i386 versión 0.7.2.2-3build6 : multimedia-audio-plugins versión 0.6ubuntu2 : agda-bin:i386 versión 2.5.3-3build1 : dynamips:i386 versión 0.2.14-1build1 : python3-cdo:i386 versión 1.3.5-3ubuntu1 : gfortran-5-multilib-mips64-linux-gnuabi64:i386 versión 5.5.0-12ubuntu1cross1 : qasconfig:i386 versión 0.21.0-1.1 : libghc-stringbuilder-dev:i386 versión 0.5.0-6build1 : debram:i386 versión 2.0.0.5 : libghc-unordered-containers-dev:i386 versión 0.2.8.0-1build2 : python-gnome2:i386 versión 2.28.1+dfsg-1.2 : python-quixote:i386 versión 2.7~b2-1.1 : caja-open-terminal:i386 versión 1.20.0-1 : libghc-lambdabot-novelty-plugins-dev:i386 versión 5.1.0.1-1build4 : jtex-base versión 2.1-1.1 : oss4-base:i386 versión 4.2-build2010-5ubuntu3~18.04.1 : oss4-base:i386 versión 4.2-build2010-5ubuntu2 : r-cran-bio3d:i386 versión 2.3-4-1 : balsa:i386 versión 2.5.3-4 : kupfer versión 0+v319-2 : libghc-generic-deriving-dev:i386 versión 1.11.2-1 : libgnustep-base-dev:i386 versión 1.25.1-2ubuntu3 : gccgo-8-powerpc-linux-gnuspe:i386 versión 8.2.0-1ubuntu2~18.04cross1 : gccgo-8-powerpc-linux-gnuspe:i386 versión 8-20180414-1ubuntu2cross1 : r-revolution-revobase:i386 versión 3.0.0-1ubuntu3 : mininet:i386 versión 2.2.2-2ubuntu1 : lvm2-dbusd:i386 versión 2.02.176-4.1ubuntu3 : gis-workstation versión 0.0.14 : gfortran-7-multilib-s390x-linux-gnu:i386 versión 7.3.0-27ubuntu1~18.04cross1 : gfortran-7-multilib-s390x-linux-gnu:i386 versión 7.3.0-16ubuntu3cross1


Me da que muchos son obsoletos pero no me gustaría estropear mi sistema (que vuelvo a decir que funciona correctamente) con esta limpia (creo que son casi 8000 paquetes).

Muchas gracias por vuestra ayuda y un saludo.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: