4 votos

No puedo crear un almacén de datos en Esxi 6.7 U1

He creado una nueva instalación de Esxi 6.7 U1 después de esto no puedo crear en ningún modo el Datastore en el disco del sistema, sólo en el segundo disco, pero ¿por qué?

enter image description here

enter image description here

enter image description here

enter image description here

enter image description here

3 votos

Por disco del sistema, ¿se refiere al disco en el que ya está instalado ESXI?

1 votos

AFAIK, si eliges disco durante la instalación, el datastore ya será asignado para todo el espacio posible y presentado justo después de la instalación. Asumiendo que el "disco del sistema" es probablemente el disco root de ESXi

3voto

Strepsils Puntos 196

Esto suele ocurrir cuando se intenta crear un datastore no en un disco vacío (unidad de sistema en tu caso). Normalmente, la reescritura del disco ayuda, pero como es el que contiene los datos de ESXi, esto no es una opción ya que los datos serán borrados. ¿Has probado a crear un volumen VMFS desde la línea de comandos? https://kb.vmware.com/s/article/1009829

Además, intente revisar el disco para ver si hay errores que causan el mensaje que ve/ Necesitará SSH para esto. Primero, liste los discos conectados y luego partedUtil getptbl /vmfs/devices/disks/(disk ID) con el ID del disco de su sistema.

0voto

Marco Puntos 91

Supongo que estoy usando tu mismo ISP ahora mismo porque acabo de instalar ESXi 6.7 U1 en un servidor dedicado y me encontré con el mismo problema.

Lo he arreglado de forma fácil:

  • seleccionado VMware ESXi 6.5 U2 en lugar de 6.7 U1 como imagen de instalación
  • después de la instalación, el datastore en el disco de instalación ya estaba en su lugar como datastore1
  • modo de mantenimiento activado
  • se ha registrado en ssh y ha habilitado el cliente http a través de esxcli network firewall ruleset set -e true -r httpClient
  • actualizado a la última versión 6.7 a través de esxcli software profile update -p ESXi-6.7.0-20191204001-standard -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
  • cliente http deshabilitado a través de esxcli network firewall ruleset set -e false -r httpClient
  • reiniciado en el ESXi 6.7 actualizado ( reboot ) y el problema desapareció

Estoy de acuerdo en que probablemente la imagen de instalación del ISP está rota.

De hecho, cobran 25 euros al día por KVM, de lo contrario, reinstalar desde una imagen de ESXi 6.7 desde el ordenador del cliente habría sido aún mejor.

0voto

OcK Puntos 28

La respuesta correcta es la siguiente aquí .

En resumen, si quieres crear un volumen VMFS en tu dispositivo de arranque, tienes que hacerlo a través de SSH.

Así es como lo arreglé en mi sistema:

[thiesi@EaglesTalon:~] partedUtil getptbl /dev/disks/t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__
gpt
97281 255 63 1562824368
1 64 204863 C12A7328F81F11D2BA4B00A0C93EC93B systemPartition 128
5 208896 1232895 EBD0A0A2B9E5443387C068B6B72699C7 linuxNative 0
6 1234944 2258943 EBD0A0A2B9E5443387C068B6B72699C7 linuxNative 0
7 2260992 15470592 4EB2EA3978554790A79EFAE495E21F8D vmfsl 0

[thiesi@EaglesTalon:~] partedUtil getUsableSectors /dev/disks/t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__
34 1562824334

[thiesi@EaglesTalon:~] partedUtil add /dev/disks/t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__ gpt "8 15472640 1562824334 AA31E02A400F11DB9590000C2911D1B8 0"
gpt
97281 255 63 1562824368
1 64 204863 C12A7328F81F11D2BA4B00A0C93EC93B 128
5 208896 1232895 EBD0A0A2B9E5443387C068B6B72699C7 0
6 1234944 2258943 EBD0A0A2B9E5443387C068B6B72699C7 0
7 2260992 15470592 4EB2EA3978554790A79EFAE495E21F8D 0
8 15472640 1562824334 AA31E02A400F11DB9590000C2911D1B8 0

[thiesi@EaglesTalon:~] partedUtil getptbl /dev/disks/t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__
gpt
97281 255 63 1562824368
1 64 204863 C12A7328F81F11D2BA4B00A0C93EC93B systemPartition 128
5 208896 1232895 EBD0A0A2B9E5443387C068B6B72699C7 linuxNative 0
6 1234944 2258943 EBD0A0A2B9E5443387C068B6B72699C7 linuxNative 0
7 2260992 15470592 4EB2EA3978554790A79EFAE495E21F8D vmfsl 0
8 15472640 1562824334 AA31E02A400F11DB9590000C2911D1B8 vmfs 0

Tenga en cuenta la AA31E02A400F11DB9590000C2911D1B8 - esta es una cadena fija que denota los volúmenes VMFS, por lo que tendrá que utilizar la misma.

Y por último:

[thiesi@EaglesTalon:~] vmkfstools -C vmfs6 -S datastore1 /dev/disks/t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__:8
create fs deviceName:'/dev/disks/t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__:8', fsShortName:'vmfs6', fsName:'datastore1'
deviceFullPath:/dev/disks/t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__:8 deviceFile:t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__:8
ATS on device /dev/disks/t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__:8: not supported
.
Checking if remote hosts are using this device as a valid file system. This may take a few seconds...
Scanning for VMFS-3/VMFS-5 host activity (512 bytes/HB, 2048 HBs).
Creating vmfs6 file system on "t10.ATA_____INTEL_SSDSC2BX800G4_____________________BTHC6203039D800NGN__:8" with blockSize 1048576, unmapGranularity 1048576, unmapPriority default and volume label "datastore1".
Successfully created new volume: 5f3837ea-e817299f-d51a-0cc47a4d717e

resultado final

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: