20 votos

Los siguientes paquetes tienen dependencias no satisfechas: nodejs : Conflictos: npm

He seguido este hilo conductor https://gist.github.com/Goddard/5500157 para instalar nodejs y npm, pero después de ejecutarlo no se pudo ejecutar ni node --version ni npm --version, dando un error de comando no encontrado. Pude desinstalar nodejs, pero tuve que ir al directorio temporal descrito en el script y hacer un make uninstall para que npm saliera.

Ahora en un intento de instalar nodejs y npm de nuevo he utilizado este enlace en su lugar http://www.andreagrandi.it/2013/02/08/how-to-install-latest-stable-node-js-on-ubuntu/ pero si intento instalar tanto nodejs como npm juntos me sale este mensaje de error.

sudo apt-get install nodejs npm

The following packages have unmet dependencies:
   nodejs : Conflicts: npm
E: Unable to correct problems, you have held broken packages.

Si sólo instalo nodejs funciona bien.

sudo apt-get install nodejs

node --version
v0.10.15

Pero ahora si intento instalar npm me da este mensaje de error

sudo apt-get install npm 

The following packages have unmet dependencies:
npm : Depends: nodejs (>= 0.6.19~dfsg1-3) but it is not going to be installed
   Depends: nodejs-dev
   Depends: node-node-uuid but it is not going to be installed
   Depends: node-request but it is not going to be installed
   Depends: node-mkdirp but it is not going to be installed
   Depends: node-minimatch but it is not going to be installed
   Depends: node-semver but it is not going to be installed
   Depends: node-ini but it is not going to be installed
   Depends: node-graceful-fs but it is not going to be installed
   Depends: node-abbrev but it is not going to be installed
   Depends: node-nopt but it is not going to be installed
   Depends: node-fstream but it is not going to be installed
   Depends: node-rimraf but it is not going to be installed
   Depends: node-tar but it is not going to be installed
   Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Estoy usando Ubuntu 13.04. Se agradece cualquier ayuda. No sé mucho sobre node.js y npm. Yo estaba tratando de empezar a aprender a utilizar estos por lo que probablemente mi falta de experiencia está mostrando.

2 votos

El paquete nodejs que instalaste desde el PPA incluye npm desde la v0.10.0. En otras palabras - usted debe tener npm instalado ya (debido a sudo apt-get install nodejs). Intenta ejecutar npm para confirmarlo. También vea el guía oficial de instalación (el que has seguido es una copia del mismo, pero el oficial tiene algunos detalles extra).

0 votos

Gracias -- tienes razón todo funciona correctamente si solo instalas nodejs y luego ejecutas npm --version. No pensé en comprobar si venían juntos, simplemente asumí que estaban separados.

0 votos

2017 y todavía es posible llegar a este punto, con el mismo mensaje de error confuso para un no error :(

25voto

cyberx86 Puntos 14100

El nodejs que ha instalado desde el PPA incluye npm desde la v0.10.0. Dado que tiene la v0.10.15, cuando ejecutó sudo apt-get install nodejs también instalaste npm . Intenta correr npm para confirmar.

Véase también el guía oficial de instalación (el que has seguido es una copia del mismo, pero el oficial tiene algunos detalles extra).

2 votos

Si npm ya está instalado, ¿por qué se confunde apt? ¿Está roto de todos modos?

0 votos

La misma situación, instalé a través de curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash - que ya tenía npm instalado.

0 votos

Esta respuesta es obsoleta. El enlace ya no es válido y el problema persiste con node v12 instalado usando las instrucciones oficiales de Ubuntu/Debian: github.com/nodesource/distributions/blob/master/

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: