2 votos

¿Por qué't mi Dell XPS wifi (iwlwifi) funciona con el kernel 4.15.0-64?

A mi el WiFi dejó de funcionar 9/23/19, y tratando de averiguar lo que ha cambiado, parece que funciona con la versión del kernel 4.15.0-60-genérico, pero no con los nuevos kernel 4.15.0-64. Alguna idea de por qué o qué hacer?

Detalles de mi configuración:

SO: Ubuntu 18.04.3

máquina: Dell XPS 15 7590

controlador de red: iwlwifi

lspci con el trabajo del núcleo:

$ lspci -nnk |grep Network -A3
3b:00.0 Network controller [0280]: Intel Corporation Device [8086:2723] (rev 1a)
  Subsystem: Bigfoot Networks, Inc. Device [1a56:1654]
  Kernel driver in use: iwlwifi
  Kernel modules: iwlwifi

sudo lshw -C network
*-network
  description: Ethernet interface
  product: Intel Corporation
  vendor: Intel Corporation
  physical id: 0
  bus info: pci@0000:3b:00.0
  logical name: wlp59s0
  version: 1a
  serial: <removed>
  width: 64 bits
  clock: 33MHz
  capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical
  configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-60-generic firmware=48.4fa0041f.0 ip=10.12.33.131 latency=0 link=yes multicast=yes
  resources: irq:16 memory:ed400000-ed403fff

[Modificar:] lspci con el roto del kernel:

*-network UNCLAIMED       
   description: Network controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:3b:00.0
   version: 1a
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix cap_list
   configuration: latency=0
   resources: memory:ed400000-ed403fff

rfkill de salida: cuando funciona (núcleo antiguo):

$ sudo rfkill list
    0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Cuando no funcionan (los nuevos núcleos):

$  sudo rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

1voto

user167850 Puntos 230
<p>Esto puede ser un error del núcleo. La forma más fácil es actualizar a un kernel HWE.<p>Ejecutar en una terminal</p><pre><code></code></pre><p>y reiniciar.</p></p>

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by:

X