5 votos

no se puede instalar wine en ubuntu (en realidad lubuntu) 18.04

He seguido todas las instrucciones que aparecen en la winehq página. En particular, he ejecute los siguientes comandos:

sudo dpkg --add-architecture i386 
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main' 

Los tres primeros de la anterior parecía funcionar bien. Sin embargo, el último comando me da el siguiente error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 5.0.0~bionic)
E: Unable to correct problems, you have held broken packages.

Yo estoy usando Lubuntu 18.04.3 en un USB con el palo en vivo. (Sin embargo, si no recuerdo mal, hace un par de días tengo exactamente el mismo error en un disco duro normal Lubuntu 18.04.3 de instalación.)

He leído que mucha gente se cometan errores similares. Por desgracia no he encontrado ninguna solución en línea que funcionó.

Cualquier ayuda sería muy apreciada. Gracias!

EDIT: Gracias por los comentarios y sugerencias de todos. Probaré a cabo el día de hoy.

Por el momento, aquí hay algo que no entiendo. Ubuntu 18.04 ha sido de alrededor de casi dos años. En todo ese tiempo, seguramente alguien ha instalado correctamente el vino, ¿verdad? Lo que hizo que hacer para que funcione?

14voto

Mark Puntos 1

Análisis

El WineHQ repositorio pierde las dependencias de wine-stable paquete.
Me han informado de un error 48513 a WineHQ bugzilla.

El principal problema aquí es la mala de la documentación, que se escriben en la forma reproducible.

El problema con las dependencias fue causado por el FAudio de dependencia, que no está contenida en Debian/Ubuntu y WineHQ los repositorios. Podemos determinar con exactitud el nombre del paquete mediante el comando de abajo y el análisis de su salida:

$ sudo apt-get install wine-stable-amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-stable-amd64 : Depends: libfaudio0 but it is not installable
                     Recommends: libcapi20-3 but it is not going to be installed
                     Recommends: libodbc1 but it is not going to be installed
                     Recommends: libosmesa6 but it is not going to be installed
                     Recommends: libsdl2-2.0-0 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

La mencionada libfaudio0 paquete sólo está disponible para Ubuntu 19.10 y los próximos 20.04 LTS.


Solución

Necesitamos seguir oficial de WineHQ guía para Ubuntu parcialmente:

sudo dpkg --add-architecture i386
sudo apt update

Nota: si usted tiene WineHQ repositorio añadido quitar con

sudo apt-add-repository -r 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main' 

para evitar el desorden de los repositorios y luego proceder.

A continuación, debemos añadir otros repositorios de OpenSuse Build Service para obtener libfaudio0 instalado:

wget -nv https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/Release.key -O Release.key
sudo apt-key add - < Release.key
sudo apt-add-repository 'deb https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/ ./'
sudo apt-get update

y sólo después de esto instalar uno de WineHQ los paquetes:

# Stable branch     
sudo apt install --install-recommends winehq-stable

#Development branch     
#sudo apt install --install-recommends winehq-devel

#Staging branch     
#sudo apt install --install-recommends winehq-staging

1voto

Como otra solución temporal, puede instalar la versión anterior con el comando

apt-get install -y --install-recommends winehq-stable=4.0.3~bionic \
wine-stable=4.0.3~bionic wine-stable-amd64=4.0.3~bionic wine-stable-i386=4.0.3~bionic

Puede ser actualizado después de mantenedores de arreglar su repositorio.

0voto

Akash Karnatak Puntos 108

Si la instalación de winehq-estable da el mismo error, incluso después de seguir todos los pasos en @N0rbert la respuesta.

Ejecutar este comando dado en este enlace

sudo apt-get install libgnutls30:i386 libldap-2.4-2:i386 libgpg-error0:i386 libxml2:i386 libasound2-plugins:i386 libsdl2-2.0-0:i386 libfreetype6:i386 libdbus-1-3:i386 libsqlite3-0:i386

Yo tenía el mismo problema y esto funcionó para mí.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: