26 votos

El altavoz interno (audio) no funciona en Ubuntu 20.04 LTS después de actualizar desde Ubuntu 18.04 LTS

Recientemente he actualizado a Ubuntu 20.04 lts desde 18.04 lts. Después de reiniciar el audio no funciona. Intenté reinstalar pulseaudio y alsa pero sigue sin funcionar. sudo apt-get install --reinstall alsa-base pulseaudio sudo alsa force-reload sigue sin funcionar.

salida

  inxi -SMA
System:    Host: Wizard Kernel: 5.4.0-26-generic x86_64 bits: 64 Desktop: Gnome 3.36.1 Distro: Ubuntu 20.04 LTS (Focal Fossa) 
Machine:   Type: Portable System: Dell product: Vostro 2520 v: N/A serial: <superuser/root required> 
           Mobo: Dell model: 0V1NDP v: A11 serial: <superuser/root required> BIOS: Dell v: A11 date: 02/24/2014 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-26-generic 

salida

 lspci 
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1c.5 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 6 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM75 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
07:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)

0 votos

Hola creo que tenemos el mismo problema...ver askubuntu.com/questions/1230383/

0 votos

Prueba este parche, estaba teniendo el mismo problema y lo arregló. answers.launchpad.net/ubuntu/+source/alsa-driver/+question/

1 votos

¿Los auriculares no funcionan desde el principio con la nueva versión de Ubuntu? ¿Necesitas instalar un paquete de una fuente no confiable para arreglarlo? Debe ser una broma ...

14voto

BlueDune Puntos 1

Sus altavoces pueden ser detectados como desenchufados, lo que hace que sean ignorados.

Solución temporal:

  1. sudo apt install pavucontrol
  2. Ejecutar pavucontrol
  3. Pestaña Configuración > Perfil > Salida analógica estéreo (desenchufada) (no disponible)

Los altavoces deberían funcionar pero se reiniciará cuando se desenchufen los auriculares o se reinicie el sistema.

Arreglo permanente:

  1. sudo apt install alsa-tools-gui
  2. Ejecutar hdajackretask
  3. Pistas del analizador > jack_detect = no
  4. Solicitar ahora
  5. Instalar boot override

1 votos

El segundo me ha funcionado, aunque haya habido mensajes de error al aplicarlo.

1 votos

He intentado todo para asus zenbook pro ux434f pero no funcionó. Finalmente la solución permanente me funcionó después de un reinicio (aunque no instalé boot override). Voy a leer la documentación y luego instalar boot override.

9voto

benjamin10 Puntos 6

Creo que tengo una solución para tu problema: Prueba con

sudo alsa force-reload

Esto devolvió la vida a mi tarjeta de sonido. Pero no sobrevive a un reinicio, así que estoy trabajando para que el cambio sea persistente... Ver:

https://www.maketecheasier.com/fix-no-sound-issue-ubuntu/

0 votos

Ya lo he intentado ver en la pregunta

0 votos

esto me funciona en el Dell XPS L502X, y sigue funcionando después de dormir.

0 votos

@geoffrey, ¿por qué no debería funcionar después de dormir?

7voto

Dominic Puntos 11

Lo que me solucionó después de una actualización a 20.04 fue:

sudo apt purge timidity-daemon

Entonces reinicia.
Rápido y fácil, ¡vale la pena probarlo!

1 votos

esto me ha funcionado. Ninguna de las otras cosas lo hizo.

2 votos

No me funcionó. No tengo instalado el demonio de la timidez

0 votos

Esto también me ha funcionado.

5voto

Rajasekharan N. Puntos 131

El mío es un Dell Inspiron 1525. Probé todas las soluciones listadas aquí en askubuntu.com y en toda la web pero de nada sirvieron y finalmente encontré que es un error en Ubuntu 20.04 LTS/kernel-5.4 (Focal kernel) donde no se detecta la tarjeta de sonido interna. El driver soc-skl está desactivado por por defecto desde el kernel-5.4. Los kernels 5.5, 5.6 han deshabilitado este driver. Lea los informes de errores aquí y aquí .

Afecta a muchos usuarios. No hay mucho que podamos hacer hasta que se arreglen los núcleos.

Para mí, los auriculares y el micrófono funcionan. De momento, conectando las tomas de auriculares a unos altavoces externos se soluciona el problema.

-1voto

Greg Puntos 99

Tengo un problema similar con el sonido de la placa que no funciona (la tarjeta de sonido externa funciona)

sudo alsa force-reload

No lo arregló para mí.

Ha registrado un problema https://answers.launchpad.net/ubuntu/+source/alsa-driver/+question/690180

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: