4 votos

Ubuntu 20.04 mínimo: "no se puede encontrar el paquete python-pip"

El lanzamiento de un pequeño VMs en BPC y pensé que daría Ubuntu 20.04 LTS mínimo de un intento. Después de hacer un "apt update; apt actualización" soy capaz de instalar los paquetes como de Apache, pero no teniendo ninguna suerte con el PIP:

root@ubuntu-rr58:/home/me# apt install python-pip
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package python-pip

He verificado el Universo, Multiverso y Restringido repositorios están disponibles:

root@ubuntu-rr58:~# grep ^deb /etc/apt/sources.list
deb http://us-central1.gce.archive.ubuntu.com/ubuntu/ focal main restricted
deb http://us-central1.gce.archive.ubuntu.com/ubuntu/ focal-updates main restricted
deb http://us-central1.gce.archive.ubuntu.com/ubuntu/ focal universe
deb http://us-central1.gce.archive.ubuntu.com/ubuntu/ focal-updates universe
deb http://us-central1.gce.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://us-central1.gce.archive.ubuntu.com/ubuntu/ focal-updates multiverse
deb http://us-central1.gce.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse deb http://security.ubuntu.com/ubuntu focal-security main restricted
deb http://security.ubuntu.com/ubuntu focal-security universe
deb http://security.ubuntu.com/ubuntu focal-security multiverse

8voto

Gerald Schneider Puntos 193

El paquete se llama python3-pip. Python 2.7 no se entregan ya con Ubuntu 20.04, casi todos python relacionados con los paquetes se llama python3-*.

3voto

deadghost Puntos 108

Para obtener el Python 2 versión de pip de nuevo, puede utilizar get-pip, que es un único script que descarga e instala la última versión de pip (para Python 2 o 3, independientemente de la versión de ejecutar el script):

$ curl -O https://raw.githubusercontent.com/pypa/get-pip/master/get-pip.py
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 1824k  100 1824k    0     0  2211k      0 --:--:-- --:--:-- --:--:-- 2211k

$ python get-pip.py 
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Defaulting to user installation because normal site-packages is not writeable
Collecting pip
  Using cached pip-20.1-py2.py3-none-any.whl (1.5 MB)
Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 20.1
    Uninstalling pip-20.1:
      Successfully uninstalled pip-20.1
  WARNING: The scripts pip, pip2 and pip2.7 are installed in '~/.local/bin' which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed pip-20.1

A continuación, agregue ~/.local/bin/ a la PATHde acceso (por ejemplo, en su ~/.bashrc):

PATH=$HOME/.local/bin/:$PATH

Después de que usted debe tener un trabajo pip de comandos de Python 2. O uso pip2 / pip2.7 si desea asegurarse de que usted no está de orientación de Python 3.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: