27 votos

Wget devuelve el error: "No se puede establecer la conexión SSL."

Cuando intento ejecutar Wget con las siguientes opciones:

Recibo el error: `` El sitio web que estoy tratando de descargar es seguro.

También he intentado cambiar el protocolo a SSLv3, pero todavía no está funcionando.

¿Puede alguien decirme por qué está haciendo esto y cómo evitarlo?

23voto

Chris Puntos 201

Puede encontrar una versión más reciente aquí: binarios de Windows de GNU Wget

Funciona bien, tuve el mismo problema.

19voto

Joseph Sible Puntos 186

Como muestra SSL Labs, minecraft.net solo admite TLSv1.0 y versiones posteriores. No puedes usar SSLv3 con él. Es probable que su versión de wget no sea compatible con esto (posiblemente debido a ser demasiado viejo). Intenta actualizarlo.

3voto

Harald Puntos 348

He descargado el archivo de 32 `` bits. Funciona.

2voto

Ivan P. Puntos 16

Tuvo un error similar, pero en mi caso sólo "No se puede establecer la conexión SSL." se mostró sin explicación. He utilizado un WinWget, que incluía un wget compilado sin compatibilidad con SSL. Resuelto descargando la versión completa de https://eternallybored.org/misc/wget/

1voto

Alex Puntos 374

Es posible que desee agregar `` la opción.

Compruebe también si openssl instalado compatible con TLS mediante la ejecución:

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: