1 votos

El interruptor DELL 6224 tiene un comportamiento extraño

Estoy teniendo problemas con mi switch DELL 6224.

Este conmutador es el nodo central de mi red, truncando entre otros conmutadores, VLANs y enrutando paquetes.

El tráfico de red que ha manejado es bastante bajo, alrededor del 20% de su capacidad total. Sin embargo está presentando un comportamiento extraño.

Ex:

A------S------B.

A=PC

S=Dell 6224

B=PC

Cuando hago ping A->B o B->A todo funciona sin problemas. Pero cuando hago ping A->S o B->S, sin importar las VLANs, el switch no responde a las peticiones de ping como se supone que debería hacer. Algunas respuestas de ping tienen tiempos de latencia altos y timeouts, como si estuviera sufriendo de sobrecarga de tráfico o si no está priorizando el tráfico ICMP dirigido a él.

¿Es normal este comportamiento? No parece serlo, al menos para mí.

Gracias de antemano.

ACTUALIZACIÓN

CPU Utilization:

 PID     Name                     5 Sec    1 Min    5 Min
---------------------------------------------------------
 336d060 tTffsPTask               0.00%    0.02%    0.00%
 3383e90 tNetTask                 0.63%    0.52%    0.34%
 3570370 ipnetd                   0.00%    0.02%    0.15%
 3582910 tXbdService              0.31%    1.38%    1.91%
 359d950 osapiTimer               0.79%    0.98%    1.09%
 368ef20 bcmL2X.0                 0.00%    0.26%    0.13%
 36a4500 bcmCNTR.0                0.00%    0.26%    0.37%
 36d75e0 bcmTX                    0.15%    0.18%    0.30%
 3cce7e0 bcmRX                    0.47%    0.66%    0.77%
 3cee9d0 bcmNHOP                  0.00%    0.02%    0.00%
 3f04a10 MAC Send Task            0.31%    0.19%    0.15%
 3f0df10 MAC Age Task             0.00%    0.05%    0.02%
 4a8e580 bcmLINK.0                0.47%    0.36%    0.28%
 4d18a10 LOG                      0.00%    0.06%    0.01%
 518f860 tL7Timer0                0.00%    0.04%    0.00%
 51b5140 osapiMonTask             0.00%    0.00%    0.08%
 5ea3d40 simPts_task              0.00%    0.12%    0.17%
 61b4ea0 UtilTask                 0.00%    0.02%    0.00%
 62d8100 dtlTask                  0.31%    0.59%    0.67%
 63398b0 tEmWeb                   0.31%    0.15%    0.06%
 6369e50 hapiRxTask               0.79%    0.31%    0.31%
 698be00 DHCP snoop               0.15%    0.04%    0.00%
 6a20eb0 Dynamic ARP Inspection   0.00%    0.05%    0.00%
 76602f0 dot1s_timer_task         0.47%    0.55%    0.62%
 849a550 unitMgrTask              0.00%    0.02%    0.00%
 863b200 snoopTask                0.00%    0.06%    0.00%
 8670640 dot3ad_timer_task        0.00%    0.02%    0.15%
 95f1690 ipMapForwardingTask      1.27%    4.90%    6.04%
 96bc9a0 tRipTask                 0.00%    0.02%    0.00%
 9aef570 IpHelperTask             0.00%    0.00%    0.01%
 9b01760 tRtrDiscProcessingTask   0.00%    0.02%    0.00%
 ca57310 voipTask                 0.47%    0.52%    0.61%
 cbe0860 lldpTask                 0.79%    0.49%    0.61%
 d838170 isdpTask                 0.00%    0.04%    0.01%
 e039950 RMONTask                 0.15%    0.10%    0.15%
 e045ff0 boxs Req                 0.15%    0.08%    0.00%
---------------------------------------------------------
 Total CPU Utilization            7.99%   13.10%   15.01%

2voto

Evan Anderson Puntos 118832

Estoy usando varios de ellos como entidades de capa 3 en una red con alrededor de 2.000 hosts y ese no es un comportamiento normal para ese switch. Suena como la forma en que ese interruptor actuaría si usted está utilizando el protocolo de árbol de expansión (STP) y la topología es thrashing. La serie 6200, en mi opinión, maneja mal los cambios de topología STP, en términos de rendimiento de la capa 3 durante el cambio de topología.

El mejor lugar para buscar, ahora mismo, sería el show process cpu y el registro del conmutador. Echa un vistazo allí, mira lo que tienes, y actualiza tu pregunta y llegaremos al fondo de la cuestión.

Editar:

Vaya. No he leído bien tu pregunta. Lo siento.

Regularmente veo alta latencia en los ecos ICMP a las interfaces de gestión y enrutamiento en los switches de la serie 6200. Han actuado así para mí a través de cada revisión de firmware que he utilizado. El motor de enrutamiento no parece dejar caer los paquetes cuando los PINGs al switch se vuelven difíciles (y ellos definitivamente se ponen feas cuando la topología del STP cambia, pero el uso de la CPU también se dispara en ese momento).

1voto

VLostBoy Puntos 136

¡He encontrado el problema!

Hubo dos cosas. Para la solución, primero habilité spanning tree en todos los switches con la configuración RSTP. Todos los puertos conectados a los dispositivos de borde, como las impresoras de los ordenadores, etc., estaban configurados con la opción PORT FAST. El problema se suavizó, pero entonces me di cuenta de que todos mis puertos/canales de puertos estaban configurados con la opción "switchport voice detect". Creo que esta opción, pone algo de procesamiento innecesario en el hardware y el switch pasa todo el procesamiento (enrutamiento y tráfico) al firmware, dejando el switch inestable. Al desactivar esta opción en todos los puertos, el problema se resolvió definitivamente. Ahora el 6224 está rockeando sólidamente con bajo uso de cpu y respondiendo a cada ping que le envié! =)

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: