19 votos

Cómo arreglar "No se encontraron tarjetas de sonido"

Estaba tratando de que la salida óptica IEC958 / SPDIF funcionara en mi placa base ASUS P8P67PRO V3 con Natty y parece que he eliminado una parte crucial de mi configuración de sonido.

Aquí está el resultado de algunos comandos relevantes (espero):

 sudo aplay -l  
aplay: device_list:240: no soundcards found...

ls /cat/asound*
ls: cannot access /proc/asoun*: No such file or directory

lspci -v
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 05)
Subsystem: ASUSTeK Computer Inc. Device 8469
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at fe720000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: oss_hdaudio
Kernel modules: snd-hda-intel

pactl stat
Currently in use: 1 blocks containing 63.9 KiB bytes total.
Allocated during whole lifetime: 41 blocks containing 1.8 MiB bytes total.
Sample cache size: 0 B
Server Name: pulseaudio
Server Version: 0.9.22-24-g67d18
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: auto_null
Default Source: auto_null.monitor
Cookie: bed7e0b0

Cualquier consejo muy apreciado.

14voto

sourish Puntos 298

Yo tuve el mismo problema. Lo resolví ejecutando el siguiente comando

 sudo modprobe snd-hda-intel

Dentro de una ventana de terminal ( Ctrl + Alt + T para abrir una).

2voto

williamtx Puntos 21

En caso de que ayude a alguien, tuve un problema similar: Alsa estaba encontrando mi tarjeta de sonido USB, pero Pulseaudio no.

Resulta que si cambié mi usuario a root (sudo su root), Pulseaudio funcionó bien. Entonces, la solución fue otorgar el permiso de 'audio' correcto a mi usuario:

 sudo adduser myuser audio

0voto

Dale Walker Puntos 1

Actualizado de 12.04 a 12.10 con la herramienta de actualización dist. Primero no hubo grub y lo reparé con rescatux. Entonces no se encontró ninguna tarjeta de sonido. Revisé página tras página y probé muchas de las soluciones, aproximadamente tres horas de trabajo cuando la solución era tan simple que me sorprende que no sea el resultado de búsqueda número uno para este problema. Aquí está:

Instale el encabezado y los archivos de imagen para su kernel.

 sudo apt-get install linux-headers-3.5.0-26-generic linux-image-3.5.0-26-generic

¡Espero que esto funcione para ti también!

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: