2 votos

La actualización de Ubuntu rompe el firefox

Actualicé ubuntu, pero la actualización rompió firefox, el plugin de adobe flash y corrompió la base de datos de paquetes. Ejecuté la reparación del catálogo sugerida, sin cambios. He ejecutado apt-get -f install ningún cambio. He ejecutado apt purge packageName, sin cambios. ¿Cómo puedo resolver esta dependencia circular?

Aquí tienes algunos detalles:

installArchives() failed: dpkg: dependency problems prevent configuration of adobe-flashplugin:
 firefox (12.0+build1-0ubuntu0.12.04.1) breaks adobe-flashplugin (<= 11.1.102.63-0precise1) and is installed.
  Version of adobe-flashplugin to be configured is 10.0.32.18-1intrepid1.
dpkg: error processing adobe-flashplugin (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of adobe-flash-properties-gtk:
 adobe-flash-properties-gtk depends on adobe-flashplugin (= 11.2.202.235-0precise1); however:
  Version of adobe-flashplugin on system is 10.0.32.18-1intrepid1.
dpkg: error processing adobe-flash-properties-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Errors were encountered while processing:
 adobe-flashplugin
 adobe-flash-properties-gtk
Error in function: 
dpkg: dependency problems prevent configuration of adobe-flash-properties-gtk:
 adobe-flash-properties-gtk depends on adobe-flashplugin (= 11.2.202.235-0precise1); however:
  Version of adobe-flashplugin on system is 10.0.32.18-1intrepid1.
dpkg: error processing adobe-flash-properties-gtk (--configure):
 dependency problems - leaving unconfigured

3voto

AlucinariOlim Puntos 155

Edite el siguiente archivo con permiso de root (por ejemplo sudo vim ):

/var/lib/dpkg/info/adobe-flashplugin.prerm

Ve a la línea:

set -e

Elimine la línea. Guarde el archivo y vuelva a emitir los comandos de actualización. (De hecho, procedí a eliminar y volver a añadir flash y Firefox).

N.B. caveat emptor: el arreglo puede tener efectos secundarios que aún no he visto pero he sobrevivido una semana.

Explicación:

El problema es que el adobe-flashplugin "prerm" (pre-remove) scriptespera que update-alternatives salga limpiamente. Nuestros sistemas (yo tuve el mismo problema) no salen limpiamente de ahí. La solución dice que se ignore el error y se siga adelante.

0voto

reverendj1 Puntos 7579

¿Se trata de un sistema actualizado? Parece que estás usando el plugin adobe-flash de Intrepid. Desinstala el plugin de Flash, luego Firefox, luego reinstala Firefox, luego el plugin de Flash.

sudo apt-get remove --purge adobe-flashplugin
sudo apt-get remove --purge adobe-flash-properties-gtk
sudo apt-get remove firefox
sudo apt-get install firefox
sudo apt-get install flashplugin-installer

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: