6 votos

Lo que podría causar un Error 101 en WAMP en Windows 7?

Yo'be estado usando WAMP para el desarrollo local durante bastante tiempo ahora, pero últimamente he estado recibiendo un Error 101 mensaje cuando me vaya localhost sitios. Es posible que este a han aparecido después de la última WAMP actualización, pero no estoy 100% seguro de esto. Si lo intento de nuevo y de nuevo, después de varios página se actualiza funciona, pero es muy molesto!

El mensaje de error exacto es:

Error 101 (net::ERR_CONNECTION_RESET): Unknown error.

Esta es mi configuración:

  • OS: Windows 7
  • Apache: 2.2.11
  • PHP: 5.2.9-2
  • WAMP: 2.0

También el local de secuencias de comandos de conectar a un servidor MySQL server, ellos no usan el local de MySQL(no sé si importa, aunque me permiten saber).

He estado buscando en los logs de apache y he encontrado los siguientes. Parece que el servidor apache mantiene reiniciar y no puedo entender por qué:

[Wed Oct 14 13:52:30 2009] [notice] Parent: child process exited with status 255 -- Restarting.
[Wed Oct 14 13:52:30 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-2 configured -- resuming normal operations
[Wed Oct 14 13:52:30 2009] [notice] Server built: Dec 10 2008 00:10:06
[Wed Oct 14 13:52:30 2009] [notice] Parent: Created child process 6784
[Wed Oct 14 13:52:31 2009] [notice] Child 6784: Child process is running
[Wed Oct 14 13:52:31 2009] [notice] Child 6784: Acquired the start mutex.
[Wed Oct 14 13:52:31 2009] [notice] Child 6784: Starting 64 worker threads.
[Wed Oct 14 13:52:31 2009] [notice] Child 6784: Starting thread to listen on port 80.
[Wed Oct 14 13:52:32 2009] [notice] Parent: child process exited with status 255 -- Restarting.
[Wed Oct 14 13:52:33 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-2 configured -- resuming normal operations
[Wed Oct 14 13:52:33 2009] [notice] Server built: Dec 10 2008 00:10:06
[Wed Oct 14 13:52:33 2009] [notice] Parent: Created child process 3572
[Wed Oct 14 13:52:33 2009] [notice] Child 3572: Child process is running
[Wed Oct 14 13:52:33 2009] [notice] Child 3572: Acquired the start mutex.
[Wed Oct 14 13:52:33 2009] [notice] Child 3572: Starting 64 worker threads.
[Wed Oct 14 13:52:33 2009] [notice] Child 3572: Starting thread to listen on port 80.

También he comprobado el Firewall de Windows y discapacitados de cualquier otra protección que tengo en este ordenador, sin mejoría.

Gracias!

5voto

Jam Puntos 21

Yo tenía el mismo problema.

  • OS: Windows 7
  • Server: Apache 2.2.17-win32
  • MySQL: 5.1.53-win32
  • PHP: 5.2.14-Win32

Reemplazando C:/<MySQL Dir>/bin/libMySQL.dll con C:/PHP/libmysql.dll resuelto mi problema.

El error se produce cuando intenta conectarse a la base de datos con mysql_connect. Se muestra en la siguiente línea en el registro de error de arriba.

[Wed Oct 14 13:52:32 2009] [notice] Parent: child process exited with status 255 -- Restarting.

De manera que Apache se bloquea cuando mysql_connect intenta conectarse. Para el uso adecuado libmysql.dll es útil aquí.

1voto

toofarsideways Puntos 1406

Me encontré con algo muy parecido a esto --- pero mi configuración incluido Drupal en adición a PHP. Así que para que Drupal gente por ahí, yo sugeriría que la comprobación de una función se llama a sí mismo de forma recursiva.

En mi caso, yo estaba tratando de mover una instalación de Drupal de una máquina a otra. El antiguo sistema había Log4Drupal habilitado y configurado para escribir en un archivo de registro en una unidad de disco y carpeta no existe en la nueva máquina. Lo que pude ver, la función de registro trató de informar de algo y cuando que no se pudo, trató de ingresar al fracaso, etc.

Para evitar el problema, era útil para buscar en la base de datos y averiguar qué archivo Log4Drupal estaba usando. La consulta de MySQL es "select * from variables en las que se nombre como 'el registro%'". He creado todas las carpetas necesarias para hacer que el camino bueno. Entonces mi Drupal sistema fue capaz de iniciar y que podría utilizar Log4Drupal la página de administración.

1voto

Phoenix Puntos 111

Yo tenía el mismo problema.

Usted debe cerrar la conexión al final del código de la página utilizando el recurso de conexión. Esto funcionó para mí:

mysql_close($conn); 

donde $conn es su base de datos MySQL de recursos de conexión de la variable que se ha utilizado para conectarse a la base de datos MySQL.

0voto

Istvan Puntos 1942

El restablecimiento de la conexión debe ser realizada por el win7 firewall, tienes que abrir el Firewall de Windows (sólo tipo al abrir menú de inicio aparecerá) y permitir explícitamente el puerto 80. Espero te sirva de ayuda.

0voto

Alfonso de la Osa Puntos 101

Me encontré con el problema y no tienen una respuesta a lo que ha causado el error,

para mí trabajado para deshabilitar de extensión mysqli. Wamp trabajó de nuevo como de costumbre (lento con xdebug), pero phpmyadmin perdido un montón de funcionalidades.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: