1 votos

Rutas estáticas para clientes VPN no funcionan en Windows Server 2008 R2 RRAS

Estoy configurando una simple VPN hub-and-spoke usando Windows Server 2008 R2 y RRAS. Va muy bien y ahora tengo un router configurado para establecer una conexión VPN con el servidor. Sin embargo, tengo problemas para configurar la ruta estática para que el servidor pueda ver la LAN detrás del router.

Cuando el router establece la conexión VPN, se le asigna una dirección IP de 10.0.0.5 (la dirección IP VPN de la interfaz interna creada por RRAS es 10.0.0.1). La LAN detrás del router es 192.168.10.0/24, así que para probar, he creado una ruta utilizando el siguiente comando:

route add 192.168.10.0 mask 255.255.255.0 10.0.0.5

Esto funciona perfectamente. Puedo hacer ping a un ordenador en la LAN remota; por ejemplo:

C:\Users\Administrator>ping 192.168.10.2

Pinging 192.168.10.2 with 32 bytes of data:
Reply from 192.168.10.2: bytes=32 time=506ms TTL=127
Reply from 192.168.10.2: bytes=32 time=536ms TTL=127
Reply from 192.168.10.2: bytes=32 time=508ms TTL=127
Reply from 192.168.10.2: bytes=32 time=506ms TTL=127

Aquí está la tabla de enrutamiento en este punto:

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0     109.228.20.1   109.228.20.174      6
         10.0.0.1  255.255.255.255         On-link          10.0.0.1    279
         10.0.0.4  255.255.255.255         10.0.0.4         10.0.0.1     24
         10.0.0.5  255.255.255.255         10.0.0.5         10.0.0.1     24
     109.228.20.0    255.255.252.0         On-link    109.228.20.174    261
   109.228.20.174  255.255.255.255         On-link    109.228.20.174    261
   109.228.23.255  255.255.255.255         On-link    109.228.20.174    261
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
     192.168.10.0    255.255.255.0         10.0.0.5         10.0.0.1     24
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link    109.228.20.174    261
        224.0.0.0        240.0.0.0         On-link          10.0.0.1    279
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link    109.228.20.174    261
  255.255.255.255  255.255.255.255         On-link          10.0.0.1    279
===========================================================================
Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric
          0.0.0.0          0.0.0.0     109.228.20.1       1
===========================================================================

Ahora, el problema viene cuando intento hacer de esto una ruta estática. En primer lugar, especifico la ruta estática utilizando las propiedades de marcación para el usuario:

Assigning the static route to the dial-in user

Después de que el cliente haya establecido su conexión, las tablas de enrutamiento tienen este aspecto:

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0     109.228.20.1   109.228.20.174      6
         10.0.0.1  255.255.255.255         On-link          10.0.0.1    279
         10.0.0.4  255.255.255.255         10.0.0.4         10.0.0.1     24
         10.0.0.5  255.255.255.255         10.0.0.5         10.0.0.1     24
     109.228.20.0    255.255.252.0         On-link    109.228.20.174    261
   109.228.20.174  255.255.255.255         On-link    109.228.20.174    261
   109.228.23.255  255.255.255.255         On-link    109.228.20.174    261
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
     192.168.10.0    255.255.255.0         10.0.0.5         10.0.0.1     23
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link    109.228.20.174    261
        224.0.0.0        240.0.0.0         On-link          10.0.0.1    279
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link    109.228.20.174    261
  255.255.255.255  255.255.255.255         On-link          10.0.0.1    279
===========================================================================
Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric
          0.0.0.0          0.0.0.0     109.228.20.1       1
===========================================================================

Nota: Parece que la métrica que he especificado ha sido ignorada, ya que la tabla muestra una métrica de 23.

Ahora, cuando intento hacer ping, me sale un fallo general:

C:\Users\Administrator>ping 192.168.10.2

Pinging 192.168.10.2 with 32 bytes of data:
General failure.
General failure.
General failure.
General failure.

Como un relativo novato, simplemente no entiendo por qué esta ruta no funciona. Parece que está bien y la única diferencia (aunque supongo que podría ser el factor clave) es la diferencia en la métrica (es decir, es 24 cuando se asigna a mano usando route add, pero 23 cuando es una ruta estática).

Agradecería cualquier ayuda.

Gracias,

Ben

0voto

Ben Abbott Puntos 21

Finalmente pude resolver este problema creando una interfaz de marcación de demanda de sólo respuesta en RRAS para cada router, creando así un enlace VPN de sitio a sitio desde cada router al servidor y creando la topografía de VPN hub-and-spoke que quería. A continuación, pude asignar una ruta estática para cada LAN a través de la interfaz apropiada y, ¡oh!, todo funciona bien.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: