2 votos

Contar valores de varias hojas en Excel

Tengo un archivo de Excel con múltiples hojas llamadas 1,2,3...31 (que representan los días de un mes). La tabla que se ve a continuación está en cada hoja, pero con diferentes valores.

RDC 1   5000
RDC 2   0
CAPS    0
TILT    0
FOAM    12500

Quiero contar los valores positivos de cada opción. Así que si CAPS tiene en 20 hojas valores positivos debería devolver "20". No tengo ningún problema en hacerlo para las 3 últimas opciones. He utilizado el forumla:

\=SUMPRODUCTO(COUNTIF(INDIRECT("'"&A2:A32&"'!B3");">0"))

image for above formula

Pero las dos primeras opciones quiero contarlas como una sola. Así que si:

  • en el día 1 RDC1 tiene valor positivo y RDC2 tiene valor 0 debería contar como 1

  • en el día 2 tanto RDC1 como RDC2 tienen valores positivos, por lo que debería contar como 1 también, no como 2

  • en el día 3 tanto RDC1 como RDC2 tienen valor 0, por lo que debería contar como 0

He intentado utilizar la fórmula (y formatear la celda de recuento total a Número sin decimales, por lo que cuando es 0,5 debería devolver 1 )

\=SUMA(IF('1'!B1>0;1;0);IF('1'!B2>0;1;0))/2 + ... para todos los días ... + SUM(IF('31'!B1>0;1;0);IF('31'!B2>0;1;0))/2

Funciona con menos hojas, pero cuando escribo la fórmula para todas las hojas devuelve un error. Y sí... es una fórmula muy larga.

¿Puede alguien ayudarme con una solución para contar los valores positivos juntos para las dos primeras opciones como se describe arriba?

3voto

Máté Juhász Puntos 2628

En lugar de COUNTIF puede utilizar COUNTIFS :

=COUNTA(A2:A32)-SUMPRODUCT(COUNTIFS(INDIRECT("'"&A2:A32&"'!B1");"=0";INDIRECT("'"&A2:A32&"'!B2");"=0"))

Tenga en cuenta que COUNTIF realiza una operación AND, por lo que si quieres contar cuando B1 O B2 es >0 entonces sólo cuenta cuando ambos son iguales a 0 y resta este número del recuento total.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: