56 votos

El Plugin de Adobe Flash es vulnerable/obsoleto en 14.04 pero no hay ninguna actualización en Firefox

Estoy usando Ubuntu 14.04 LTS. Cuando abro un sitio que requiere el plugin de flash (por ejemplo, Youtube), Firefox dice que Este plugin es vulnerable y debe ser actualizado.

Screenshot

Sin embargo, si hago clic en buscar actualizaciones... no hay ninguna actualización. Esto es lo que el sitio de actualización de la lista:

  1. Shockwave Flash 11.2 r202 (estado hasta la fecha 11.2.202.424)
  2. Java(TM) Plug-in 11.25.2 (estado hasta la fecha 11.25.2)

Entonces, ¿qué debo hacer?

51voto

DJCrashdummy Puntos 639

He hecho algunas investigaciones en el mozilla y adobe y pruebas con ambos reciente LTS-versiones (14.04 y 12.04) y estoy bastante seguro de que es sólo una numeración problema de la flash-plugin!

Para hacer corta una historia larga:
Si abre en firefox "herramientas" - "complementos" - "complementos", respectivamente mirar el mozilla verificación y tienes la versión 11,2,202,425 (aviso de las comas!), recibirá este mensaje de error.
y si su versión es 11.2.202.425 (misma versión, sólo con puntos en la numeración) todo está bien.

Así que no cunda el pánico, el sistema es seguro! ;-)


Pero puedo entender que este mensaje es molesto y lo que esta sería la forma más fácil de deshacerse de él:
abrir un terminal e inserte sudo apt-get update && sudo apt-get install -y flashplugin-installer, escriba su contraseña de usuario root (no se mostrará caracteres) y sólo tiene que esperar hasta ejecutado!


Yo recomendaría esta solución sólo en el caso de que ya haya instalado la última versión, pero sigue apareciendo el mensaje de error debido a las diferencias entre el flash-paquetes!

7voto

Jean Desjardins Puntos 71

La mejor solución para el problema de un vulnerables, fuera de la fecha de instalación de Flash, o incluso un up-to-fecha de uno que funciona mal, que puede ser para desinstalar Flash totalmente. A menudo no es necesario, como HTML5 ha tomado el relevo. Por lo tanto la eliminación de Flash es una solución real para muchas personas, y probablemente debería ser considerado primero antes de pasar a otras soluciones que intentan mantener Flash instalado, mientras que el mantenimiento en la actual (o semi-actual) del estado.

Como occupyflash.org dice:

Flash Player está muerto. Su tiempo ha pasado. Está plagado de errores. Se cuelga mucho. Se requiere constantes actualizaciones de seguridad. No funciona en la mayoría de los los dispositivos móviles. Es un fósil, a la izquierda de la época de cerrado normas y control corporativo unilateral de la tecnología web. Sitios web que se basan en Flash ofrecen una completamente incoherente (y a menudo inutilizable) la experiencia para el rápido crecimiento del número de usuarios que no utilice un navegador de escritorio. Presenta algunas miedo de seguridad y los problemas de privacidad de las cookies de Flash.

Flash hace que la web sea menos accesible. En este punto, lo que está frenando la web.

7voto

Rambaldy Puntos 41

A veces, esto podría ayudar a... Al menos, eso me ayudó...

sudo apt-get purge flashplugin-installer

sudo apt-get install adobe-flashplugin

4voto

sHAKaJaada Puntos 51

Como se anunció por parte de Adobe Adobe Flash Player 11.2 será la última versión para Linux de destino como una de las plataformas soportadas.

2voto

Kirill Simonov Puntos 31

El principal problema de esta situación es la versión antigua de Flash Player en Firefox, que es 11.2
En el mismo tiempo, los usuarios de Google Chrome disfrutar de la última versión compatible con Google.

El truco es cambiar de Firefox usando el Flash Player a la Pimienta Flash Player de Google Chrome.

  1. Primero de todo vamos a eliminar que tenemos:

    sudo apt-get remove flashplugin-installer
    sudo apt-get remove adobe-flashplugin

  2. Instalar Fresco Player Plugin por Rinat Ibragimov.
    Es el contenedor que permite a los usuarios de Linux para el uso de la Pimienta de Flash (que se incluye con el Google Chrome en Firefox y otros NPAPI compatible con los navegadores web.
    Versión más reciente en este momento es 0.3.1, y todo parece funcionar.

    sudo add-apt-repository ppa:nilarimogard/webupd8
    sudo apt-get update
    sudo apt-get install freshplayerplugin

  3. Instalar Pimienta propio Flash Player de Google Chrome Estable:

    sudo apt-get install pepperflashplugin-nonfree
    sudo update-pepperflashplugin-nonfree --install

    Si usted desea, puede instalar flash player desde diferentes versiones:

    Google Chrome Beta:

    sudo update-pepperflashplugin-nonfree --install --beta --no verificada

    Google Chrome Inestable:

    sudo update-pepperflashplugin-nonfree --install --inestable, sin verificar

Ahora es el momento para comprobar la versión:

  1. Adobe Acerca de la muestra que tengo 18,0,0,209
  2. about:addons muestra que tengo la versión 13.1 r2
  3. Mozilla Comprobar los Plugins de la página de muestra que tengo la versión 13.1.2.3, es anticuado y ofrece actualizar ahora, pero la actualización no funciona (y no lo necesitamos, en realidad)

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: