22 votos

Clearsigned archivo no es válido, de 01.org paquete?

Estoy corriendo Ubuntu 14.04 LTS, y tengo una HD 4600 integrada chip de gráficos.

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)

Intel acaba de lanzar la nueva versión de sus controladores Gráficos para Ubuntu 14.04.
https://01.org/linuxgraphics/downloads/2014/intelr-graphics-installer-1.0.5-linux

Cuando intento instalar, me quedo atascado en:

Finished : E:GPG error: http://download.01.org trusty InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)  [  ] ◦
main-window.c/on_transaction_finished: Package transaction finished with an error

Y previene sudo apt-get update de finalización. Me sale el mismo error que antes.

Fui a "Software Y Actualizaciones" y el "Otro Software" en la ficha, y quita el mal repositorio: http://download.01.org/gfx/ubuntu/14.04/main, y luego pude actualizar mi repositorios. Pero no puedo instalar el Controlador de Gráficos Intel!

Espero estar haciendo sentido. Este es el primer día de este está disponible, por lo que yo estoy contando con Intel para solucionar esto pronto, si no, espero que alguien pueda ayudar a encontrar un trabajo a su alrededor.

38voto

xikamo Puntos366

El instalador contiene el mal url del repositorio. Para solucionar esto es necesario:

  1. Iniciar el programa de instalación y prueba de instalar, usted ha obtenido un error, cerrar el instalador.
  2. Abrir la consola y escribir:

    sudo gedit /etc/apt/sources.list.d/intellinuxgraphics.list
    
  3. Reemplazar texto con texto de abajo, no cerrar gedit acaba de salir:

    deb https://download.01.org/gfx/ubuntu/14.04/main/ trusty main #Intel Graphics drivers
    
  4. Inicie el instalador de nuevo, pulse el botón inicio, pulse el botón de Instalar y rápido de cambiar a gedit y mantenga pulsado CTRL+S.


sudo apt-get update puede dar:

GPG error: https://download.01.org trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A902DDA375E52366

Arreglar con:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys A902DDA375E52366

2voto

Dusan Milosevic Puntos827

Aquí está la solución más fácil para aquellos con problemas de:

  1. Abrir Nautilus(el explorador de archivos), ir a Editar -> Preferencias -> Comportamiento, y asegúrese de que en Ejecutable archivos de texto, Pida que cada vez está seleccionado!(si no, seleccione ella)
  2. Cerrar la ventana
  3. Abrir Nautilus(si no está ya abierto)
  4. Haga clic derecho -> Nuevo documento -> documento Vacío
  5. Nombre script.sh(es importante para acabar con el .sh)
  6. Abrirlo y rellenarlo con esto:

    #! /bin/bash while [ 1 ]; do sudo sed --in-place 's/http:/https:/g' /etc/apt/sources.list.d/intellinuxgraphics.list sleep 1 done

  7. Guardar y cerrar

  8. Haga clic derecho sobre script.sh -> Permisos
  9. De verificación Permitir ejecutar este archivo como programa
  10. Cerrar la ventana
  11. Haga doble clic en él
  12. Seleccione Ejecutar en la terminal
  13. Introduzca la contraseña
  14. NO cerrar el terminal
  15. Comenzar la instalación, y todo debería funcionar

También me dio Error al recuperar download.01.org/gfx/ubuntu/14.04/main/pool/main/i/... no coincide el Tamaño de error y esto se ha solucionado el problema. Usted puede eliminar el archivo de secuencia de comandos y cerca de la terminal cuando la instalación haya finalizado.

Edit: no Hay manera más sencilla:

  1. Escriba esto en la terminal:

    #! /bin/bash while [ 1 ]; do sudo sed --in-place 's/http:/https:/g' /etc/apt/sources.list.d/intellinuxgraphics.list sleep 1 done

  2. Introduzca la contraseña

  3. Ejecutar el instalador

0voto

mchid Puntos8951

El uso de gdebi para instalar el intel-linux-gráficos-installer y no tienen la GPG problemas. Se debería instalar automáticamente con el paquete deb. Utilice los siguientes comandos para hacerlo:

sudo apt-get update && sudo apt-get install gdebi
cd && wget https://download.01.org/gfx/ubuntu/14.04/main/pool/main/i/intel-linux-graphics-installer/intel-linux-graphics-installer_1.0.6-0intel1_amd64.deb
sudo gdebi intel-linux-graphics-installer_1.0.6-0intel1_amd64.deb
intel-linux-graphics-installer

Siga las instrucciones que se muestran en la interfaz gráfica de usuario para actualizar su sistema. Guarden su trabajo y reinicie para que los cambios surtan efecto.


Además, el uso de

sudo apt-key adv

Se considera un riesgo para la seguridad y no es recomendado, ya que son "minar todo el concepto de seguridad como esto no es una forma segura de recibir las llaves, por diversas razones (como por ejemplo: hkp es un texto del protocolo, cortos y largos, incluso keyids puede ser forjado, ...)". http://ubuntuforums.org/showthread.php?t=2195579

Creo que la forma correcta es la primera importación de la clave

GET https://download.01.org/gfx/RPM-GPG-KEY-ilg | gpg --import

Verificación de la huella dactilar

gpg --check-sigs --fingerprint 75E52366

Obtener la clave de que el servidor

gpg --keyserver pgpkeys.mit.edu --recv-key 7CB0FA13

Exportar la llave de su llavero

gpg -a --export 75E52366 | sudo apt-key add -

Repita para el segundo clave

GET https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 | gpg --import

gpg --check-sigs --fingerprint 2F4AAA66

gpg --keyserver pgpkeys.mit.edu --recv-key 144BD458

gpg -a --export 2F4AAA66 | sudo apt-key add -

más info http://www.debian.org/doc/manuals/securing-debian-howto/ch7.en.html#s-deb-pack-sign

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: