12 votos

Cómo habilitar el registro de error en lighttpd correctamente?

Tengo un Centos 5 con sistema de Lighttpd y fastcgi habilitado. Se hace log de acceso, pero no los errores de registro. He Internal Server Error 500 y no hay información en el registro y cuando intento abrir no-existente de archivo también - no hay información en el registro de errores. Cómo habilitar correctamente?

A continuación está la lista de los módulos que he habilitado:

server.modules              = (
                               "mod_rewrite",
                               "mod_redirect",
                               "mod_alias",
#                                "mod_access",
#                               "mod_cml",
#                               "mod_trigger_b4_dl",
#                               "mod_auth",
                               "mod_status",
                               "mod_setenv",
                               "mod_fastcgi",
#                               "mod_webdav",
#                               "mod_proxy_core",
#                               "mod_proxy_backend_fastcgi",
#                               "mod_proxy_backend_scgi",
#                               "mod_proxy_backend_ajp13",
#                               "mod_simple_vhost",
#                               "mod_evhost",
#                               "mod_userdir",
#                               "mod_cgi",
#                               "mod_compress",
#                               "mod_ssi",
#                               "mod_usertrack",
#                               "mod_expire",
#                               "mod_secdownload",
#                               "mod_rrdtool",
                                "mod_accesslog" )

Aquí está la configuración de la depuración:

## enable debugging
#debug.log-request-header     = "enable"
#debug.log-response-header    = "enable"
#debug.log-request-handling   = "enable"
debug.log-file-not-found     = "enable"
#debug.log-condition-handling = "enable"

Configuración de la ruta de acceso a error y registro de acceso:

## where to send error-messages to
server.errorlog             = "/home/lxadmin/httpd/lighttpd/error.log"

#### accesslog module
accesslog.filename          = "/home/lxadmin/httpd/lighttpd/ligh.log"

Configuración de fastcgi:

fastcgi.debug = 1

fastcgi.server = ( ".php" => ((
                     "bin-path" => "/usr/bin/php-cgi",
                     "socket" => "/tmp/php.socket",
                     "max-procs" => 12,
                     "bin-environment" => (
                         "PHP_FCGI_CHILDREN" => "2",
                         "PHP_FCGI_MAX_REQUESTS" => "500"
                         )
                 )))

Y en incluido el archivo config que tengo:

server.errorlog    =  "/home/httpd/mywebsite.com/stats/mywebsite.com-error_log"

Lo que viene en los archivos de registro:

/home/httpd/mywebsite.com/stats/
-rw-r--r-- 1 apache apache 5173239 May 16 11:34 mywebsite.com-custom_log
-rwxrwxrwx 1 root   root         0 Mar 27  2009 mywebsite.com-error_log

/home/lxadmin/httpd/lighttpd/
-rwxrwxrwx  1 apache apache    2184 Apr 22 22:59 error.log
-rwxrwxrwx  1 apache apache 6088621 May 16 11:26 ligh.log

Me dio registros de error chmod 777 para intentar comprobar si es el problema, pero al parecer no lo es.

Así que mi pregunta es: ¿qué hacer para tener un registro de errores habilitado?

8voto

E. Yazici Puntos 347

A diferencia de Apache y nginx, no se puede utilizar por cada virtual host de archivos de registro para los mensajes de error en lighttpd. server.errorlog variable es global en lighttpd, consulte la Función de Solicitud #665 para obtener más detalles.

7voto

Marco Ramos Puntos 2212

Su error_log parece estar bien configurado.

¿Has probado a lsof su lighttpd proceso para ver si tiene el error_log abierto?

lsof -p `pidof lighttpd`

Por otro lado, tratar de strace el mismo proceso, mientras que obligaban a un error interno que se produzca:

strace -o strace.out -p `pidof lighttpd` 

Echa un vistazo a strace.. Esto podría ser útil no sólo el descubrimiento de por qué el error_log no está escrito, sino también a depurar el error interno del servidor propio problema.

Aplicar la misma "receta" para los procesos fastcgi. Mi conjetura es que esto está relacionado con las conexiones fallando entre lighttpd y procesos fastcgi.

Espero que esto ayude.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: