34 votos

Cómo habilitar TLS 1.1, 1.2 en IIS 7.5

Queremos apoyar a los navegadores web que utilizan TLS 1.1 y 1.2, que aparentemente ha sido implementado por Microsoft, pero está desactivado por defecto.

Así que busqué en Google y descubrí algunas páginas que todo el mundo parece estar siguiendo:

http://support.microsoft.com/kb/245030

http://derek858.blogspot.com/2010/06/enable-tls-12-aes-256-and-sha-256-in.html

Sin embargo No parece funcionar para mí. He configurado ambos bóvedas DWORD para DisabledByDefault y Enabled para TLS 1.1 y 1.2. Puedo confirmar que mi cliente está intentando comunicarse con TLS 1.2, pero el servidor sólo responde con 1.0. He reiniciado IIS, pero no ha cambiado la situación.

Microsoft señala: "ADVERTENCIA: El valor DisabledByDefault en las claves de registro de la clave Protocols no tiene prioridad sobre el valor grbitEnabledProtocols que está definido en la estructura SCHANNEL_CRED que contiene los datos para una credencial Schannel".

Bueno, eso es muy vago para mí. No puedo encontrar ningún lugar donde SCHANNEL_CRED esté definido o establecido, todo lo que puedo determinar es que es una estructura definida en una biblioteca de Microsoft. Esa es mi única suposición de por qué esto no funciona, pero no puedo encontrar suficiente información sobre ello para determinar si es el verdadero problema.

50voto

Shane Madden Puntos 81409

Reiniciar. Los cambios en la configuración del canal no tienen efecto hasta que el sistema se reinicia.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: