71 votos

¿Por qué es ssh agente de reenvío no funciona?

En mi propia computadora, ejecutando MacOSX, tengo esto en ~/.ssh/config

Host *
ForwardAgent yes
Host b1
ForwardAgent yes

b1 es una máquina virtual con Ubuntu 12.04. Yo ssh como este:

ssh pupeno@b1

y mi sesión de usuario sin que se le pida la contraseña porque ya he copiado mi clave pública. Debido a la expedición, yo debería ser capaz de ssh para pupeno@b1 de b1 y se debe trabajar, sin que me pide una contraseña, pero no es así. Me pide una contraseña.

Lo que me estoy perdiendo?

Este es el resultado detallado de la segunda ssh:

pupeno@b1:~$ ssh -v pupeno@b1
OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to b1 [127.0.1.1] port 22.
debug1: Connection established.
debug1: identity file /home/pupeno/.ssh/id_rsa type -1
debug1: identity file /home/pupeno/.ssh/id_rsa-cert type -1
debug1: identity file /home/pupeno/.ssh/id_dsa type -1
debug1: identity file /home/pupeno/.ssh/id_dsa-cert type -1
debug1: identity file /home/pupeno/.ssh/id_ecdsa type -1
debug1: identity file /home/pupeno/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.9p1 Debian-5ubuntu1
debug1: match: OpenSSH_5.9p1 Debian-5ubuntu1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA 35:c0:7f:24:43:06:df:a0:bc:a7:34:4b:da:ff:66:eb
debug1: Host 'b1' is known and matches the ECDSA host key.
debug1: Found key in /home/pupeno/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/pupeno/.ssh/id_rsa
debug1: Trying private key: /home/pupeno/.ssh/id_dsa
debug1: Trying private key: /home/pupeno/.ssh/id_ecdsa
debug1: Next authentication method: password
pupeno@b1's password:

109voto

J. Pablo Fernández Puntos 1427

Resulta que mi clave no estaba en el agente, y esto arreglado:

ssh-add -K

8voto

  1. Verifique si sus ./ssh/id_rsa .ssh/id_dsa .ssh/id_ecdsa archivos tienen los permisos correctos que deben ser propiedad de su nombre de usuario y chmoded 600.

  2. Compruebe que tiene el público correcto clave en pupeno/.ssh/authorized_keys en b1 y comprobar si authorized_keys tiene una línea de rotura en el extremo de la llave.

  3. Compruebe si tiene ssh-agent corriendo, intenta cargar claves a través de introduzcas

  4. Trata de autenticación GSSAPI y reenvío con ssh -K

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: