25 votos

Nvidia X Server Settings sólo muestra 1 de la pantalla (ordenador portátil + monitor externo conectado)

Recientemente he instalado una copia nueva de Ubuntu 14.04 en mi Dell M3800 que tiene Nvidia Quadro K1100M de la tarjeta gráfica.

Más tarde también he conectado mi monitor externo a través de HDMI (HDMI a DVI conector). Entonces empecé a ver lento funcionamiento de la pantalla en la pantalla de mi laptop. Por el lento me refiero a que mis pulsaciones de teclas o acciones parece ser siempre rezagado. Curioso, esto parece ocurrir sólo en la pantalla de mi laptop, mi monitor externo funciona bien.

He hecho asegúrese de instalar y utilizar los controladores propietarios de Nvidia 331.38.

Así que he comprobado mi Ssytem Ajustes > Muestra. Y se muestra correctamente 2 screeens como se ve a continuación.

enter image description here

Pero luego me fui a Nvidia X Server settings y muestra sólo una pantalla con una gran resolución de pantalla de como se ve a continuación.

enter image description here

Creo que esta es la causa de mi portátil para tener un rendimiento lento, porque estoy asumiendo que botht el monitor externo y la pantalla de mi laptop tiene una diferente frecuencia de actualización de pantalla.

Yo soy el dumping xorg.conf & xandr salida a continuación,

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 331.38  (buildmeister@swio-display-x64-rhel04-15)  Wed Jan  8 19:53:14 PST 2014

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "nvidia" 0 0
    Inactive       "intel"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    BusID          "PCI:0@0:2:0"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    BusID          "PCI:2@0:0:0"
EndSection

Section "Screen"
    Identifier     "intel"
    Device         "intel"
    Monitor        "Monitor0"
EndSection

Section "Screen"
    Identifier     "nvidia"
    Device         "nvidia"
    Monitor        "Monitor0"
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "ConstrainCursor" "off"
    SubSection     "Display"
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

xrandr de salida,

cdtank@cdtank-Dell-Precision-M3800:~/work$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 16384 x 16384
eDP-1-0 connected 1920x1080+0+0 344mm x 193mm
   1920x1080      60.0*+   59.9  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0     60.0  
   960x720        60.0  
   928x696        60.1  
   896x672        60.0  
   960x600        60.0  
   960x540        60.0  
   800x600        60.0     60.3     56.2  
   840x525        60.0     59.9  
   800x512        60.2  
   700x525        60.0  
   640x512        60.0  
   720x450        59.9  
   640x480        60.0     59.9  
   680x384        59.8     60.0  
   576x432        60.1  
   512x384        60.0  
   400x300        60.3     56.3  
   320x240        60.1  
VGA-1-0 disconnected
HDMI-1-0 connected 1920x1080+1920+0 598mm x 336mm
   1920x1080      60.0*+
   1600x1200      60.0  
   1680x1050      59.9  
   1400x1050      59.9  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x800       59.9  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
DisplayPort-1-0 disconnected
HDMI-1-1 disconnected

ACTUALIZACIÓN Después de quitar el xorg.conf y reiniciar. Aquí está el contenido de la misma.

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:2@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
EndSection

0voto

dragonfly Puntos1

Así que tengo el mismo problema ahora mismo. Estoy corriendo 3.16.3 como mi versión de kernel y la versión 343 de la nvidia controladores propietarios.

Notas:

El Ubuntu aplicación de Controladores me muestra como usar el driver nouveau. (Yo no soy)

Tengo dos pantallas, pero no puedo configurar. El Ubuntu configuración de Pantalla me permite hacer cambios, pero los cambios no se aplican realmente. La nvidia configuración de la aplicación tiene el mismo bug como el tuyo; mi muestra se muestra como una pantalla de largo.

-1voto

Arch User Puntos1

Compruebe si el controlador está en uso:

$ lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2

Si no es de la lista negra del controlador incorrecto:

$ sudo echo nouveau >> /etc/modprobe.d/blacklist.conf

reinicie y vuelva a mirar el controlador que está en uso.

Si el controlador está en uso y todavía el problema, entonces usted necesita para configurar el xorg.conf archivo.Aquí es una buena wiki, cómo configurar el xorg.conf para dos pantallas

-1voto

Michael Puntos487

Usted podría tratar de establecer screen0="buildtin", y screen1="monitor1", y que es en xorg.conf, y usted podría usar gedit desde el terminal, y que es en estas dos secciones aquí:

      section monitor
      section screen

y podría funcionar bien de esta manera.

-1voto

Yo beleve he encontrado el problema de su GPU tiene Nvidia optimus, este reqiers el abejorro paquetes.

Primero retire su controlador en software y actualizaciones, configurar el nouvo o nouvell (yo no ahora, ¿cómo explicar que el open source).

sudo apt-get install --no-install-recommends bumblebee bumblebee-nvidia:

Va a instalar y el mejor piloto.

Reinicio y echar un vistazo

-2voto

baestynator Puntos1

Su problema puede ser con los drivers de NVidia.

Trate de usar el open source Nouveau conductores.

Ir a la página de Controladores y seleccione "Open Source - Nouveau" opción.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by:

;