9 votos

Cómo instalar los últimos mono en una distro de Linux aparte de Suse (por ejemplo, Debian/Ubuntu)?

¿Cómo se hace para instalar una versión reciente de mono en una distro de linux aparte de Novell Suse?

http://www.mono-project.com/Main_Page promete un "Linux" en la descarga, sino que "sólo" ofrecer descargas de Suse y enlaces a versiones obsoletas de mono ( < versión 2).

Tengo un compilador y no tengo miedo a usarlo ... pero se sienten mucho mejor que si alguien puede me apunte a un "Cómo instalar Mono en Debian/Ubuntu" descripción o muéstrame dónde descargar un .deb de la versión más reciente.

5voto

Yaser Sulaiman Puntos 1420

De http://www.mono-project.com/Other_Downloads:

Mono está disponible en la versión estable de Debian liberación y en las versiones posteriores. Para desarrollar software con Mono, instale el mono-devel paquete en Etch (4.0) usando aptitude o similares gestor de paquetes.

Tan sólo apt-get install mono-devel, tal vez?

ACTUALIZACIÓN: La versión de Mono que usted conseguirá de Ubuntu 8.04 es 1.2.6, mientras que usted está probablemente en busca de 2.0.1, que viene con la 9.04. Probablemente su mejor apuesta es para actualizar a Jaunty. Existe una posibilidad de que la descarga de la Jaunty .deb e instalar en su máquina va a funcionar, pero yo no apostaría por ello.

3voto

zigdon Puntos 101

Para ubuntu, muchos más actualizada de los paquetes están disponibles mediante el Paquete de Archivos de launchpad.net.

Si estás usando ubuntu 8.04 (hardy), el más relevante parece ser https://launchpad.net/~mono-edge/+archive/ppa

Si desea que el realmente al borde del precipicio, mono, entonces no es un mono-pruebas de PPA con mono 2.4 https://launchpad.net/~mono-testing/+archive/ppa

Para instalar paquetes desde un PPA, y obtener actualizaciones para ellos, siga estas instrucciones.

3voto

Mark McDonald Puntos 246

Tiempo resuelto mi Problema para mí ... mono es ahora en UBUNTU

UBUNTU 9.10 ha instalable paquetes para el mono, incluyendo algunas herramientas de integración que hacen de asambleas (thingy.exe) se puede usar desde la CLI


Gracias a todos los que contribuyó con respuestas y sugerencias.

1voto

Gishu Puntos 59012

Siga las instrucciones aquí para configurar backports y acceso a repositorio de debian.

entonces

aptitude -t etch-backports install mono-2.0-devel

0voto

William Brendel Puntos 15453

Si desea utilizar la versión más reciente de mono en un más viejo (por ejemplo, el apoyo a largo plazo de la versión) de Ubuntu, puedes agregar el oficial de repositorios backports a /etc/apt/sources.lista y simplemente instalar con apt-get.

Parece mono aún no estaba adaptado a la 8.04, mirando thepackages lista http://packages.ubuntu.com/hardy-backports/allpackages

Sin embargo, usted puede simplemente solicitar un backport. Hay una buena probabilidad de que va a ser añadido para usted.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: