9 votos

Error en la instalación del SDK de Windows (la versión más Reciente ya instalado)

Estoy tratando de instalar el SDK de Windows en mi Windows 7 de 64 bits de la máquina.

Pero durante el proceso de instalación me dio un error. He revisado el registro y parece que es debido a una versión más reciente de Microsoft Visual C++ 2010 tiempo de ejecución ya está instalado (10.0.40219 está instalado en comparación con 10.0.30219, que está disponible en el paquete). Tal vez no es compatible o es que tiene otro problema.

Puedo desinstalar este paquete e instalar el de mayor edad de la SDK de Windows, pero en el caso de que éste no era el problema, ¿cómo puedo devolver el paquete? Windows Update?

11voto

Vijay Varadan Puntos 216

Me encontré con el mismo problema. La solución es desinstalar "Microsoft Visual C++ Compiladores de 2010 Estándar - enu - x86", pero no hay ninguna entrada en el Panel de Control/Programas y Características para ello. Además, es posible que necesite desinstalar:

Microsoft Visual C++  Compilers 2010 Standard - enu - x64

Nota: hay 2 espacios entre las palabras de C++ y Compiladores.

La forma en que me imaginé fue haciendo una búsqueda en el registro de la por encima de los 2 términos. Cuando usted encuentra una clave de registración con un nombre de visualización que corresponde a cada una de las cadenas de arriba, buscar el valor en LocalPackage vas a encontrar el nombre de el archivo MSI para el uso de desinstalar utilizando las instrucciones de abajo.

Inicie un símbolo del sistema con privilegios administrativos. Navegar a C:\Windows\Installer. Ejecute el siguiente comando:

C:\Windows\Installer>msiexec /x <LocalPackage reg string value here>

Responder " Sí " a las peticiones y esto va a limpiar completamente. Repita para el otro de la cadena si es necesario. Esto le permitirá hacer una instalación completa de Windows SDK 7.1

Tenga en cuenta que en mi caso, tuve Visual C++ 2010 Express edition instalado seguido por VS2010 SP1. Basado en los resultados de búsqueda web, parece que este problema es causado por la instalación del SP1. También, quería desinstalar todo y sólo instalar Windows SDK 7.1 - así que, he borrado cosas. Otra alternativa de solución es desactivar la casilla "Visual C++ Compiladores" cuando la instalación de Windows SDK 7.1 y mantener a los existentes de la versión más reciente e instalar el resto de la SDK correctamente.

Esta página tiene más relevante e información importante: http://msdn.microsoft.com/en-us/visualc/gg697159

6voto

Blo grat Puntos 61

Microsoft parece haber lanzado una corrección para esta realidad, KB2519277.

Usted no necesita desinstalar el VS2010 SP1 compiladores de más, ni tratar de encontrar la correcta paquete de msi para desinstalar.

Si usted está tratando de instalar el SDK para un sistema con VS2010 actualización de SP1 instalado, simplemente anular la selección de los compiladores en el SDK de instalador e instalar todo lo demás que usted desea. Después de que el SDK instalado, ejecutar el "Microsoft Visual C++ 2010 Service Pack 1 Compilador de Actualización para el Windows SDK 7.1" para instalar el SDK de compiladores.

Si usted está tratando de reparar un SDK de instalar que el VS2010 actualización de SP1 quitado los compiladores de, simplemente hay que ejecutar el "Microsoft Visual C++ 2010 Service Pack 1 Compilador de Actualización para el Windows SDK 7.1" y vuelva a instalar los compiladores.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: