7 votos

¿Cómo instalo el controlador de video Intel HD 3000?

¿Cómo instalo un controlador de vídeo nuevo?

Necesito instalar al controlador de video Intel HD 3000 en mi PC que corre Ubuntu 10.04.

6voto

Paul Beckingham Puntos 7460

Sandy Bridge de Gráficos, tales como la HD3000 la necesidad de una actualización de la Mesa de apoyo más allá de lo que está disponible para Lúcido.

Uno de los mejores PPAs con una mesa de la versión que ha backports para soporte de Sandy Bridge es de Stefan Glasenhardt.

NO me gustaría instalar el instalar el x-org canteadoras de PPA, que es a menudo citado. x-org canteadoras - como los propios desarrolladores de decir - es muy inestable y puede causar importantes problemas de gráficos ya que las actualizaciones son frecuentes y a menudo escasamente probada.

Puesto que usted está utilizando un portátil moderno, también se requieren más arriba-hasta la fecha Kernel 2.6.38 que está disponible desde Synaptic Manager.

Cómo instalar:

sudo add-apt-repository ppa:glasen/intel-driver
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install linux-image-generic-lts-backport-natty linux-headers-generic-lts-backport-natty

Nota

Trabajando con el OP - esta solución sólo funciona para 32 bits de Ubuntu. De 64 bits de Ubuntu con esta solución te dejará con un congelado/mal estado de los gráficos y, como tal, debe ser evitado.

2voto

Cry Havok Puntos 970

La mejor solución es probablemente actualizar a 10.10 y 11.04. Ya tiene los controladores más recientes disponibles.

Alternativamente se dispone de controladores para 10.04, con algún riesgo de inestabilidad:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update

Como se documenta en los propios forosde Ubuntu.

0voto

cweiske Puntos 1917

10.04 es demasiado viejo para hacer que funcionen, tienes que actualizar a 11.04.

Pero incluso con eso, los controladores de Intel 3000 en un Macbook Air (4,1/4,2) no funcionará correctamente debido a errores en el kernel de linux. Ver http://keithp.com/blogs/MacBook-Air-2 para una explicación de esto. El resultado es que usted necesitará Linux Kernel versión 3.2 para conseguirlos trabajando plenamente.

0voto

Nico Puntos 21

después que hiciste lo que 'fossfreedom' publicada sólo cambia la siguiente línea en/etc/default/grub'

 GRUB_CMDLINE_LINUX_DEFAULT="quite splash"

Para

 GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=1"

también se puede ver >> este Post <<

0voto

prabind Puntos 1

GRUB_CMDLINE_LINUX_DEFAULT="quite splash i965.modeset=0es realizable en el puente de arena. También tenga cuidado al actualizar el sistema. Utilizar solamente debajo de comando:

sudo add-apt-repository ppa:glasen/intel-driver
sudo apt-get update && sudo apt-get upgrade
sudo apt-get install linux-image-generic-lts-backport-natty linux-headers-generic-lts-backport-natty

Instalar lucid 1.04 y usar sobre el código.

Gracias a chicos, después de mucho tiempo, buen post. Muchas gracias a Glasen.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: