6 votos

Magento no ver mcrypt en la LÁMPARA

Estoy corriendo Ubuntu 13.10 y de escritorio instalado una pila lamp (Apache 2.4.6, y la Versión de PHP 5.5.3-1ubuntu2), y establecer los hosts virtuales. Yo también apt-get ed php5-curl, y php5-mcrypt (sin errores al instalar)

Estoy tratando de configurar un Magento (1.8.0.0) entorno de desarrollo y el error que estoy recibiendo es:

PHP extension "mcrypt" must be loaded.

¿Cómo se "carga" mcrypt?

10voto

Berek Bryan Puntos 349

No parece ser un problema con la mcrypt paquete en el que no se incluye en los mods disponibles después de ser instalado.

Para solucionarlo, simplemente:

sudo ln -s /etc/php5/conf.d/mcrypt.ini /etc/php5/mods-available/mcrypt.ini
sudo php5enmod mcrypt
sudo restart apache2

Si el último comando no funciona, hacer sudo service apache2 restart lugar.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: