30 votos

Error en la línea de comandos "El sistema no puede encontrar la ruta especificada".

No estoy seguro de lo que hice, pero desde hace 5 semanas, pero estoy recibiendo este error The system cannot find the path specified. cuando ejecuto cualquier comando o inicio cmd. Esto es lo que obtengo cuando inicio la línea de comandos:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
The system cannot find the path specified.

C:\Users\Jason>

¿Cómo puedo solucionar este error?

42voto

quark8 Puntos 6845

Prueba lo siguiente.

  1. Abra el Editor del Registro (pulse <img src="https://i.stack.imgur.com/zc21b.png" alt=""> + R , tipo regedit y golpear Enter ) .
  2. Navegue hasta HKEY_CURRENT_USER\Software\Microsoft\Command Processor\AutoRun y borrar los valores.
  3. Compruebe también HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor\AutoRun .

<a href="http://carol-nichols.com/2011/03/17/the-system-cannot-find-the-path-specified/" rel="noreferrer">Fuente</a>

0 votos

Mira también HKLM \SYSTEM\CurrentControlSet\Control\Session Gerente \Environment para el ComSpec

1 votos

¿Algún otro truco? Tengo el mismo problema, pero no tengo AutoRun en el Procesador de Comandos?

0 votos

Lo mismo digo, ninguna de las rutas tiene "AutoRun"

3voto

Taibhse Puntos 21

Tu Ruta de acceso debe estar equivocada. El problema es que el símbolo del sistema no puede encontrar cualquiera de los programas para que coincida con lo que usted está entrando.

  • Desde tu escritorio, haz clic en "Mi pc" y haz clic en "Propiedades"
  • En la ventana Propiedades del Sistema, haz clic en la ficha "Avanzadas".
  • En la sección de "opciones Avanzadas", haz clic en el botón "Variables de Entorno".
  • En la ventana de las "Variables de Entorno", resalta (selecciona) la variable de Ruta de acceso en los Sistemas de sección Variable y haz clic en el botón "Editar".

No sé la ruta de acceso predeterminada de los valores que necesitas, pero apostaría que tienes algo que no está bien. Post lo tienes aquí.

0 votos

Había un par de caminos no válidos. Las eliminé, reinicié pero seguía obteniendo el mismo error. He comprobado la ruta de mi nombre de usuario y también del sistema.

0 votos

El mismo problema si ejecuto CMD (como administrador) no hay error. Si ejecuto un cmd como usuario "normal" también obtengo este error cada vez que invoco "CMD" Y puedo excluir con toda seguridad que el PATH esté estropeado - ya que para probarlo he borrado todas las entradas del mismo y el error SIGUE apareciendo.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: