16 votos

¿Cómo puedo instalar la última versión de desarrollo de ImageMagick sin compilar?

Tuve algunos problemas con ImageMagick y me dijeron Ubuntu por defecto del paquete ImageMagick es una antigua versión y que debo actualizar a resolver mis problemas.

¿Cómo puedo hacer eso? Tengo la última versión de Ubuntu (12.10). Sináptica me muestra 8:6.7.7.10-2ubuntu4 como la última versión de IM. Significa que mi IM versión es 6.7.7.10 (convert --version salidas de la misma). IM no proporciona deb binarios de sí mismo. Debian tiene algo más reciente, pero en algunas pruebas/ramas experimentales si he entendido bien. He encontrado IM en Launchpad, pero no hay instrucciones de cómo agregar esto a mis fuentes, parece que no es uno de los habituales PPAs me encuentro en la búsqueda de la última/versión beta del software. No sé cómo trabajar con este.

Es allí una manera de cómo marcar un paquete para ser tomadas de algunos filo de las fuentes y dejar el resto de mi sistema para ser tomado de estándar fuentes? Sería, probablemente, el mejor es actualizar a la última versión estable de IM (6.8), pero que es, probablemente, sci-fi, no es ni siquiera en Debian. Sin embargo, necesito al menos 6.7.9.


Nota: quiero evitar compilación de origen. No me gusta tener instalado algo y no ser capaz de manipular con facilidad con apt-get o Synaptic. Por otra parte, no hay actualizaciones para los programas compilados. Siempre me compilar me siento como que va en contra del sistema, como el uso de pegamento, alambre y cinta aislante. No, no quiero compilar seguro.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: