5 votos

¿Cómo downgrade rhythmbox v2.98?

He estado probando el nuevo PPA de WebUpd8 para Rhythmbox que he utilizado para la actualización de Rhythmbox v2.97 a v2.98.

Sin embargo, cuando he añadido este PPA, cuando uso mi favorito de los plugins replaygain y coverart-browser, Rhythmbox se bloquea con un fallo de segmentación.

Peor aún, cuando este accidente ocurre, mi Unidad de escritorio se vuelve inestable, con varias aplicaciones no se inicie con similar fallas de segmentación.

¿Alguien sabe la razón de esto - pero lo más importante es cómo resolver esto?

4voto

Paul Beckingham Puntos 7460

¿Por qué chocar...

Los plugins antes - replaygain y la portada del disco-navegador están codificados en el lenguaje llamado Python.

Para ello se utiliza el gi de la introspección de las bibliotecas.

Estos bug-los informes son relevantes:

Precisa utiliza una versión anterior del paquete importante pygobject - parece que el Rhythmbox los desarrolladores han utilizado las bibliotecas más recientes se encuentran en la Cuántica.

He confirmado que el PPA de webupd8 funciona a la perfección en la Cuántica - no hay problemas con estos plugins.

Sin embargo, el accidente es causado por algún código en Rhythmbox v2.98 que está llamando a las cosas en las mayores bibliotecas, que no es manejado y las causas del accidente.

Ya que las partes de la Unidad y algunas aplicaciones de Gnome también igualmente utilizar pygobject, el accidente se parece a salir de este paquete de bibliotecas en un estado indefinido causando la inestabilidad.

El RB de los desarrolladores han reconocido este - pero es raro para resolver esto.

opciones de...

Por lo tanto no es una opción - vivir sin estos plugins y demás afectados de manera similar, o para degradar su Rhythmbox versión.

Para pasar de la v2.98:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:webupd8team/rhythmbox

Luego de la limpieza:

sudo apt-get purge rhythmbox gir1.2-rb-3.0 librhythmbox-core5 rhythmbox-mozilla rhythmbox-data rhythmbox-plugin-zeitgeist rhythmbox-plugin-magnatune rhythmbox-plugin-cdrecorder librhythmbox-core6 rhythmbox-plugins

es decir, el ppa-purge no limpiar completamente y deja un poco de las bibliotecas aún en su v2.98 versiones.

Rematar mediante la actualización de sus fuentes:

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install rhythmbox

Esto te dejará con la predeterminada y estable Rhythmbox 2.96 que viene con Precisión.

Si usted todavía tiene un anhelo por algo un poco más nuevo, he reconstruido WebUpd8 original de Rhythmbox v2.97 antes de que el equipo actualizado.

Este está disponible en mi PPA.

sudo add-apt-repository ppa:fossfreedom/rhythmbox
sudo apt-get update && sudo apt-get install rhythmbox

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: