5 votos

lm-sensors no puede llegar a la CPU y de la placa base de la temperatura/velocidad del ventilador

He instalado lm-sensors y corrió sensors-detect con éxito. Es editado mi /etc/modules para los módulos requeridos (lm85, i2c-i801 y coretemp) sería cargar durante el arranque.
He añadido también una muy buena applets mi parte superior del panel de Gnome.

Pero no se puede obtener ninguna información. Escribir sensors en la terminal simplemente me da cero valores, excepto para cpu0_vid (siempre +2.050 V), y coretemp-isa-0000 y 0001 (siempre 42°C).

Los applets de seguir diciendo "Error al actualizar el sensor de XXX", como "se ha producido Un error al intentar actualizar el valor del sensor de la CPU Ventilador situado en el sensor://lm85-i2c-3-2e/20", y el sensor de la CPU de los' sensor://lm82-i2c-3-2e/32.

¿Qué está pasando? Todos los módulos se carguen correctamente, supongo. Y los sensores reportados por los applets yo he elegido (y cambiado de nombre, 'cos "CPU Fan" es mejor que "cpu_fan") es Preferences cuadro de diálogo.

[EDITAR]

sensors de salida

lm85-i2c-0-2e
Adapter: SMBus I801 adapter at e000
V1.5: +0.00 V (min = +0.00 V, max = +3.32 V)
VCore: +0.00 V (min = +0.00 V, max = +2.99 V)
V3.3: +0.00 V (min = +0.00 V, max = +4.38 V)
V5: +0.00 V (min = +0.00 V, max = +6.64 V)
V12: +0.00 V (min = +0.00 V, max = +15.94 V)
CPU_Fan: 0 RPM (min = 0 RPM) ALARM
fan2: 0 RPM (min = 0 RPM) ALARM
fan3: 0 RPM (min = 0 RPM) ALARM
fan4: 0 RPM (min = 0 RPM) ALARM
CPU Temp: +0.0°C (low = -127.0°C, high = +127.0°C)
Board Temp: +0.0°C (low = -127.0°C, high = +127.0°C)
Remote Temp: +0.0°C (low = -127.0°C, high = +127.0°C)
cpu0_vid: +2.050 V

coretemp-isa-0000
Adapter: ISA adapter
Core 0: +42.0°C (high = +78.0°C, crit = +100.0°C)

coretemp-isa-0001
Adapter: ISA adapter
Core 1: +42.0°C (high = +78.0°C, crit = +100.0°C)

2voto

ramayac Puntos 1830

Haga clic en el sensor-applet y mirar a los Sensores de la ficha. No todo lo informado por el applet es proporcionada por lm_sensors, así que primero asegurarse de que el problema es con los sensores de salida. En tu caso, creo que es.

Si esto es cierto, ejecutar los sensores de comando en el terminal para comprobar si esto funciona bien. Con éxito si se le da lecturas de los sensores, que acababa de volver a instalar sensors-applet.

sudo apt-get --purge remove sensors-applet
sudo apt-get install sensors-applet

Si hay algún problema para obtener los valores de los sensores para el ventilador de la CPU y la CPU, entonces usted debe comprobar soporte para su dispositivo en particular en el lm-sensors dispositivos de soporte de la página.

Nota, lm-sensors proyecto también proporciona una secuencia de comandos independiente de la versión de sensores de detección que es probable que sea más reciente que la versión empaquetada, y podría mejorar la detección de los sensores en su máquina. Sólo se necesita perl para el trabajo.

En caso de que usted está pensando en volver a ejecutar los sensores de detección, yo primero quitar el /etc/modules entradas agregadas por la ejecución anterior. Debe estar presente en un bloque con un comentario en la parte de arriba que dice que la entrada fue añadido por los sensores de detección:

# Generated by sensors-detect on xxxx


Actualización:
Parece que no podría en realidad tener un lm85 chip.

De la lectura de los informes de otros usuarios que reportaron errores similares, parece que su chip es incorrecto detectado o está deshabilitado. Busca a través de este muy similares reporte de error en el lm-sensors sitio. De hecho, a partir de tu comentario ("lm82 0-002e: a Partir de supervisión") parece que tu sistema ha detectado el lm82 chip en el arranque. Este chip debe utilizar el lm83 módulo del controlador de acuerdo con lm-sensors, no lm85.

En este punto, no estoy seguro de que si usted puede conseguir más significativas de ayuda fuera de la lm-sensors equipo. Te sugiero que revise su sistema de especificaciones de hardware para determinar el chip que en realidad es el presente, y por separado, abra un ticket en el lm-sensors sitio detallando sus problemas. Ellos son los expertos, y que parecen ser increíblemente útil.

Búsqueda de lm85-i2c-0-2e y te das cuenta de que no estamos solos frente a este problema.

0voto

Brian Vallee Puntos 61

Acepto la corrección! Los sensores de detección es más limpia y adecuada respuesta.
(+2).


Edad: la coordinación con CÓMO: Instalar y configurar lm-sensors

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: