6 votos

OpenWRT: configuración básica de red

Acabo de instalar OpenWRT 12.09 en mi router, pero llegó a ser un poco confundido acerca de las interfaces/puentes/vlan. My router

Después de mi primer arranque, en que se registra y establecer mi contraseña de root, así que he usado Luci para activar el Wi-Fi, y me tomó un poco para darse cuenta de que yo podría puente Wi-Fi con LAN para obtener acceso a la internet. Pero terminé con dos problemas:

  1. Las direcciones DHCP de mi ISP (lo cual es malo ya que tengo que pagar una tarifa adicional por cada IP)
  2. Yo no puedo bloquear SHH acceso de Internet/WAN, así que mi router es un poco vulnerable.

¿Cómo debo configurar-preferiblemente por Luci-hacer lo siguiente:

  • DHCP proporcionada por este router para mi los dispositivos Internos, con la resolución de DNS
  • Mi dirección externa (LAN/eth0) proporcionado por el módem del ISP (por lo que no puedo sencillo bloquear el puerto 68 en esta interfaz)
  • Configurar correctamente mi interfaces para que yo pueda permitir SSH solo en interno (WAN/radio0) de la interfaz

Que y por qué debería elegir el uso de un puente o una VLAN? Este artículo, no se explicarlo, ni dar ninguna pista.


Algunas notas: - Yo soy un usuario de Gentoo Linux, así que me considero un buen estudiante, pero todavía no se ha encontrado ninguna buena referencia para OpenWRT. - Mi dispositivo es TP-Link TL-MR3020 por la forma en que tiene sólo una LAN/interfaz eth0 y uno wirelss/radio0 uno.

Actualización: Aquí están algunos de mis archivos de configuración para revisión; tl;dr

Este es mi '/etc/config/dhcp' archivo

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option leasetime '12h'
        option limit '15'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

Este es mi '/etc/config/network' archivo

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option gateway '192.168.100.1'
        option dns '192.168.100.1'
        option ipaddr '192.168.100.2'
        option netmask '255.255.255.0'

Este es mi /etc/config/wireless archivo

config wifi-device 'radio0'
        option type 'mac80211'
        option macaddr '64:66:b3:4d:8b:ce'
        option hwmode '11ng'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option txpower '27'
        option country 'US'
        option channel 'auto'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'EDITED'
        option encryption 'psk-mixed'
        option key 'EDITED'

1voto

simongcc Puntos 86

Parece que usted está haciendo todas las configuraciones de la línea de comando.

He tratado de OpenWRT antes y me he instalado el WebGUI para ayudar, usted puede referirse a LuCI esenciales para la configuración de la Interfaz de Usuario Web por LuCI. El acceso a través de navegador web para configurar el router, tales como encender SSH y configurar algunas otras configuraciones será más fácil a través de la interfaz de usuario Web.

Edición 1.

Así que tienes 3 preguntas, me separe de ellos y tratar de fijar el punto de la solución de uno por uno para una fácil comprensión. Una de las cosas tienen que declarar que, ya que mi Router es girado de OpenWRT a DDWRT y luego se convirtió en el Tomate. Así que he usado VM(Máquina Virtual) para la captura de la pantalla y soluciones escritos. Por favor, perdonar si hay 1 o 2 leve puntos de diferencia. Creo que es el mismo, la mayoría de los casos, puesto que he utilizado VM para tratar de OpenWRT antes de flash a mi router.

Preparativos: (en caso de que no lo has hecho), la LuCi se accede más tarde, cuando el router está configurado para ser accesible por red de área local de las máquinas. Extraído de LuCI Essentials

Instalar LuCi por los siguientes comandos

opkg update
opkg install luci # without https OR
opkg install luci-ssl # with https support
/etc/init.d/uhttpd start # Start the web server (uHTTPd) manually
/etc/init.d/uhttpd enable # if you wish to start automatically on reboot

1. Mi dirección externa (lan/eth0) proporcionado por el módem del ISP (por lo que no puedo sencillo bloquear el puerto 68 en esta interfaz) Supongo que te refieres a obtener la dirección externa, a la derecha? En realidad, al configurar el router para obtener el DHCP de su proveedor de internet(módem), a continuación, su dirección externa se apareció en LuCi más tarde.

Esta configuración debe hacer el trabajo:

vim /etc/config/network # edit network settings
save

#add the following lines to config
config 'interface' 'wan' # config the interface wan
        option 'proto' 'dhcp' # use protocol DHCP
        option 'ifname' 'eth1' # Physical interface name to assign to, this should be the network port connected to the your ISP modem, may vary eth1 or eth0 or whatever in your case

>>>command
ifup wan # bring WAN interface up

Hasta este punto, cuando se abra el equipo cliente como Windows 7, abra un navegador, escriba en 192.168.100.1 (en su caso), entonces usted debe ver el OpenWRT interfaz en el navegador. La contraseña no es nada de forma predeterminada.

Algo parecido a esta pantalla:

enter image description here

2. DHCP proporcionada por este router para mi los dispositivos internos, con la resolución del dispositivo de nombres (DNS)

Cuando usted puede conectarse a su router a través de cliente de navegador de la computadora, usted puede ir a Network -> Hostnames a asignar manualmente el nombre de host para dispositivos específicos si los dispositivos no tiene nombre o no se resuelve automáticamente. (en mi caso, por defecto no tienen ningún problema)

3. Configurar correctamente mi interfaces para que yo pueda permitir ssh solo en interno (wan/radio0) de la interfaz

de acuerdo con Acceso Seguro documento en OpenWRT

"al permitir que el servidor SSH dropbear y el Servidor web uhttpd no escuchar en el exterior/puerto WAN"

Aquí está cómo hacerlo:

vim /etc/config/dropbear
save

# add the following line to your dropbear
option Interface 'lan' # only listen to lan

>>>command
/etc/init.d/dropbear restart # or reboot if it doesn't work

Creo que debería ilustrar la solución de imagen a sus preguntas.

1voto

Rafareino Puntos 214

He hecho un poco de investigación y encontrar lo que quiero.

cuando usted compra un router lo que esperamos es que debe ser capaz de iniciar sesión en/ conectarse a cualquier autenticaciones proceso con su proveedor de internet, la dirección, y actuar como un servidor DHCP y NAT para todos los dispositivos (cableada o inalámbrica) dentro de su red.

He encontrado lo que estaba buscando en la wiki de OpenWRT, y sobre todo, lo que necesitas es un poco de una explicación de que lo que yo estaba buscando es un Enruta AP.

Espero que esta respuesta puede guiar a alguien.

Editar:

Empecé por la configuración de mi wifi Wifi config

Que puedo configurar diferentes zonas para cada interfaz y configurar los firewalls reglas para dirigir el tráfico entre ellos.

Notwork zones and rules

Hice toda mi configuración, siguiendo la guía y en los archivos de texto, pero la interfaz de la web funciona bien si lo hacen con cuidado.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: