4 votos

¿Cómo instalar a controladores inalámbricos de Qualcomm Atheros AR9565?

Compré un portátil HP con el Qualcomm Atheros AR9565 adaptador inalámbrico (QCWB335). Entiendo que este adaptador no es soportado actualmente en Ubuntu 12.04 y no hay manera para obtener acceso inalámbrico.

Instalé el compat-wireless-3.6.6-1 ath9k driver y no funcionó, lshw -C network todavía demostró *-network UNCLAIMED después de reset.

¿Cómo puedo averiguar cuando Ubuntu tendrá driver para AR9565? ¿Hay una solución para conseguir funcionamiento inalámbrico de alguna manera?

4voto

Arinjoy Basak Puntos 21

He aquí una manera de solucionar esto. Yo tenía el mismo problema que se menciona aquí. He seguido dos puestos en ubuntuforum por anoop-n2 y chili555, y que una mezcla de cosas, que pueden ser esquematizadas de la siguiente manera:

Usted necesita tener linux-headers-generic y build-essential instalado, trate de

sudo apt-get install linux-headers-generic build-essential

que va a ser de la más reciente versión si ya están allí.

El siguiente debe ser hecho en un terminal como root:

sudo -i
wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.9-rc4/compat-drivers-3.9-rc4-2-s.tar.bz2
tar xvf compat-drivers-3.9-rc4-2-s.tar.bz2
cd compat-drivers-3.9-rc4-2-s/
./scripts/driver-select ath9k
make

Ahora, esto probablemente dará el siguiente error:

error: redefinition of ‘kref_get_unless_zero'
include/linux/kref.h:47:32: note: previous definition of ‘kref_get_unless_zero' was here

En este caso, abra el archivo de encabezado, y encontrar todo el bloque de la función:

static inline int __must_check kref_get_unless_zero(struct kref *kref)
{
    return atomic_add_unless(&kref->refcount, 1, 0);
}

Siguiente comentario fuera de todo el bloque de la función usando la línea de comentario (put // delante de cada línea) o bloque de comentario en c como

/*static inline int __must_check kref_get_unless_zero(struct kref *kref)
{
    return atomic_add_unless(&kref->refcount, 1, 0);
}*/

a continuación, escriba los siguientes comandos uno por uno:

make
make install

A continuación, cargar el controlador utilizando

modprobe ath9k

o reinicie el sistema. Después, el wifi debería estar trabajando.

3voto

Ian Suttle Puntos 2225

El dispositivo está cubierto en este paquete: http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.6/compat-wireless-3.6.6-1-snpc.tar.bz2

Los archivos con letras adicionales, en este caso snpc, son previamente parches para agregar características y, a veces, más nuevos dispositivos. El tuyo es un buen ejemplo.

0voto

Ian Suttle Puntos 2225

El compat-wireless paquete probablemente requerirá la adición de su pci.id a la pci.c archivo, así como algunos otros cambios, similar a este: http://ubuntuforums.org/showpost.php?p=12201881&postcount=35

Se te ocurrió hacer eso? Aprender de su pc.id con:

    lspci -nn | grep 0280

Puede haber una versión de compat-wireless que incluye el dispositivo. Si vas a publicar los detalles, estaremos encantados de ayudarle.

-1voto

user65913 Puntos 6

Me gustaría probar a usar Linux Mint, como yo estaba teniendo problemas con este chip-set también en mi Debian dist. Una de las personas sugirieron Menta y llegó a trabajar en la primera instalación, no sólo wifi, pero todas las cosas de la comunicación. Tal vez el tiempo para cambiar de distro!

Hice resolver mis problemas con un backport y ahora que está instalado yo no tengo ningún problema con el AR9565 conjunto. Podría mirar disponible backports para ver si hay una pista de apoyo.

Es barato para descargar y grabar un DVD con Menta vivir sólo de arranque y ver si es compatible, en lugar de golpear su cabeza. Estoy seguro de que va a apoyar el suyo, porque es compatible con la mía! Además, cualquier persona que hable con la voluntad de entender que el chip-set se admite en algún lugar en el mundo Linux y no pasan la mitad de su tiempo a debatir si es compatible o no. Además, es agradable y cálido pelos de punta a tener que venir y trabajar después de todo el trabajo que usted pone en él!

-2voto

JoseH_Chicago Puntos 1

Qualcomm Atheros QCA8172 en Lenovo G505 - Ubuntu 13.04 funciona perfectamente en Lenovo G505 - Asegúrese de que hacer una instalación limpia de Ubuntu 13.04 vs un 'reinstalar'. Wi-Fi/LAN teclado ratón que todo funciona perfectamente.

Había pasado todo el día buscando drivers, pero los incluido en ubuntu 13.04 ya soporta Qualcomm Atheros QCA8172 driver tarjeta de red. Saludos

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: