4 votos

Sináptica y aptitud roto después de la actualización de 15.10 a 16.04

después de actualizar Ubuntu Gnome 15.10 (Astuto hombre Lobo) a 16.04 (Xenial Xerus), no puedo iniciar sináptica o de aptitud para la instalación de nuevo software, y 'apt-get install lo que' no funciona bien. Aquí está el error siempre me sale:

El valor de la " wily no es válido para APT::Default-Release como una liberación no está disponible en las fuentes.

He leído mucho acerca de este error en Google, etc., pero las soluciones proprosed en la web sólo funciona para versiones anteriores de Ubuntu o Debian. Lo he intentado por ejemplo, fue la comprobación de que el valor de APT::Default-Release en /etc/apt/apt.conf, pero no está ahí, no está establecido en cualquier archivo de texto dentro de /etc/apt/ o de cualquiera de sus subdirectorios. He eliminado todos los archivos desde el directorio /etc/apt/sources.list.d, debido a que estos estaban relacionados con antiguas versiones de Ubuntu.

Más ideas?

P. S. 1: Un poco más de información acerca de mi entorno:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04 LTS
Release:    16.04
Codename:   xenial

P. S. 2: Salida desde sudo apt edit-sources (eliminado las líneas comentadas):

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial main restricted
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial main restricted

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates main restricted
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates main restricted

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial universe
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial universe
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates universe
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates universe

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial multiverse
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-updates multiverse

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-backports main restricted universe multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-backports main restricted universe multiverse

deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security main restricted
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security main restricted
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security universe
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security universe
deb http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security multiverse
deb-src http://ubuntu.mirror.lrz.de/ubuntu/ xenial-security multiverse

deb http://archive.canonical.com/ubuntu xenial partner
deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://archive.canonical.com/ xenial partner

1voto

Abra /etc/apt/apt.conf.d/01ubuntu uso de nano, como

sudo nano /etc/apt/apt.conf.d/01ubuntu

A continuación , escriba el siguiente:

APT::Default-Release "xenial";

Limpia tu apt de caché mediante la ejecución de:

sudo rm -rfv /var/lib/apt/lists/*

Luego de crear el la partial directorio donde fue eliminado por el comando anterior:

sudo mkdir -pv /var/lib/apt/lists/partial

Para asegurarse de que usted ha limpiado de tus listas, ejecute el siguiente comando:

sudo apt clean && sudo apt autoclean

Ahora, actualizar su repositorio de información:

sudo apt update --fix-missing

Esto debería arreglar sus errores.

0voto

Amias Channer Puntos 1

que el espejo estaba roto hasta temprano en la mañana , ver la fecha y la hora en la Xenial carpetas. Debería funcionar ahora.

http://ubuntu.mirror.lrz.de/ubuntu/dists/

Su mejor utilizar el estándar redirector para su país, en cambio, como no habría incluido un espejo roto.

http://de.archive.ubuntu.com/ubuntu/

0voto

Suriya Puntos 74

Si usted tiene problemas con "atrapado" apt o más alta a nivel de programas aptitude o synaptic, una limpieza de la caché de apt puede ser necesario.

Este es el caso, especialmente después de una distribución de la actualización.

sudo apt clean

es rápido y fácil y le ayuda con un montón de paradas de apt sistemas. Yo lo hago habitualmente después de un montón de actualizaciones se han realizado, o después de un dist-upgrade.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: