4 votos

OpenWRT no WLAN local si la WLAN para ser redistribuido falla/no está disponible

Estoy tratando de configurar mi TP-Link TL-MR3020 ejecución de OpenWRT para redistribuir una red inalámbrica, por ejemplo, para cuando esté viajando y estar en un hotel.

Hasta ahora, mi configuración funciona bastante bien si la red inalámbrica está disponible y listo para ser conectado. Si no es así, o tengo por ejemplo un error tipográfico en el SSID o la clave WPA en algún lugar, de OpenWRT no sólo no llevar la red a ser redistribuidos, pero también de no conseguir los 'locales' de la WLAN. Esto no es tan malo si tengo un ordenador portátil con un puerto Ethernet disponible - pero sería muy horrible si estoy de viaje con sólo un iPad a mi disposición.

Mi relevantes (AFAIK) los archivos de configuración son como sigue:

/etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option proto 'dhcp'
    option 'ifname' 'wlan0-1'

/etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option macaddr '64:70:02:6a:03:ae'
    option hwmode '11ng'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option country 'DE'
    option channel '13'
    option txpower '20'

config wifi-iface
    option network 'lan'
    option ssid 'tlmr3020'
    option device 'radio0'
    option mode 'ap'
    option encryption 'psk2'
    option key '....'
    option disabled '0'
    option wmm '1'

config wifi-iface
    option network 'wan'
    option ssid '....'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option key '....'
    option disabled '0'
    option wmm '1'

Un wifi up , mientras que tener un error tipográfico en el SSID para ser redistribuido me pone el siguiente resultado:

command failed: Device or resource busy (-16)
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 64:70:02:6a:03:ae and ssid "tlmr3020"
Successfully initialized wpa_supplicant

No muy obvio mensaje de error aquí, el command failed siempre viene (incluso en conecta correctamente), no parece tener ningún impacto en absoluto.

logread parece indicar que netifd trata de obtener alguna IP a través de DHCP para la interfaz wan, que por supuesto va a fallar ahora. Parece que nunca tiempo de espera/hacer algo más, aunque.

Jan 15 12:14:54 tlmr3020 daemon.notice netifd: wan (13582): udhcpc (v1.19.4) started
Jan 15 12:14:54 tlmr3020 daemon.notice netifd: wan (13582): Sending discover...
Jan 15 12:14:57 tlmr3020 daemon.notice netifd: wan (13582): Sending discover...
Jan 15 12:15:00 tlmr3020 daemon.notice netifd: wan (13582): Sending discover...

De esta manera, el tlmr3020 red inalámbrica nunca llega, la eliminación de mi capacidad para conectarse a la MR3020 sobre-el-aire - bastante incómodo, por decir lo menos.

Alguien tiene una idea de qué hacer aquí para que el 'host' conexión wlan error correctamente, no afectan a la 'local' de la red? He buscado y probado casi todo lo que podía pensar, no llegar a ninguna parte.

Gracias!

3voto

Timothy Ha Puntos 101

Ya que la pregunta era capaz de solucionar el problema gracias a la información que se encuentra en el openwrt foros.

Como este billete estados

Si wpa_supplicant pierde la conexión que se va a ir en una exploración activa del ciclo que hace que la wiphy inservible para el ap de modo de operación, por lo tanto, la ap se toma hacia abajo si el sta pierde su asociación. Que no es nada que se puede fijar fácilmente y no hay planes actuales para resolver esto.

Para hacer que el router de trabajo me tuve que implementar una solución propuesta por el miembro del foro warchild - uno que funciona muy bien para mí. Utiliza el botón WPS para desactivar la falta de red de cliente. Si la red es derribado, el análisis de ciclo se rompe y el ap funciona como se esperaba; uno puede conectarse a la WLAN, solucionar los problemas (como un nuevo SSID para conectarse a/cambiar contraseña) y llevar la red a ser redistribuidos copia de seguridad.
La secuencia de comandos, así como punteros para el botón de configuración se pueden encontrar en este post (con información adicional más arriba en el hilo).

0voto

Helios Puntos 1

Tal y como yo lo veo, el TL-MR3020 se ejecuta con openwrt no admite el uso de canal 13. Yo tenía el mismo problema. Canal 11 parece funcionar ok.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: