84 votos

Cómo eliminar temporalmente las credenciales en caché de un recurso compartido de red en una máquina de Windows sin reiniciar o cerrar la sesión

Esto es más una curiosidad que un problema real, soy demasiado perezoso para reiniciar o desconectar mi portátil.

Me he conectado a una red compartida en un servidor de Windows con credenciales de dominio de una máquina de Windows 7 sin dominio, no he marcado la opción de recordar la contraseña.

La parte es digamos \\10.10.10.10\folder .

He cambiado la contraseña de esa cuenta de dominio mientras tanto, y ahora cuando trato de acceder a esa parte obtengo el siguiente error:

Fallo de inicio de sesión: nombre de usuario desconocido o contraseña incorrecta

He intentado lo siguiente en el lado del cliente:

  • Eliminar las credenciales almacenadas en el gestor de credenciales

  • corriendo net use delete

  • corriendo net session \\ip.of.the.server /delete me dice: "No existe una sesión con ese nombre de ordenador".

  • corriendo net use \\10.10.10.10\folder /u:DOMAIN\USER password me da "El comando completado con éxito", pero sigo obteniendo el mismo nombre de usuario desconocido o la misma contraseña incorrecta al intentar acceder al recurso compartido desde el Explorador de Windows

  • mapeando la acción como una unidad de red desde la interfaz gráfica de usuario, pero luego obtengo

    La carpeta de red especificada está actualmente mapeada con un nombre de usuario y una contraseña diferentes.
    Para conectarse utilizando un nombre de usuario y contraseña diferentes, primero desconecte cualquier mapeo existente a esta red compartida.

  • corriendo net use para ver las conexiones, entiendo que no hay conexiones en la lista

  • matando explorer.exe y empezar de nuevo.

He intentado lo siguiente en el lado del servidor:

  • yendo a Gestión de ordenadores > Carpetas compartidas > Sesiones para matar la sesión con mi nombre de usuario
  • reiniciando el servidor

He conseguido acceder a la acción usando el nombre de dominio en lugar de la dirección IP, pero tengo curiosidad.

¿Alguien sabe cómo borrar las credenciales almacenadas en este caso? ¿Dónde se almacenan las credenciales en caché cuando no se marca la opción de recordar la contraseña al acceder al recurso compartido, no se muestran en el Administrador de credenciales y no se muestra el mapeo cuando se ejecuta el uso de la red.

69voto

StriplingWarrior Puntos 56276

Para borrar toda la autenticación de la red

C:\> net use * /d

Para ver la conexión de red actual

C:\> net use 

NOTA IMPORTANTE

Probé en Windows 7 SP1 64 Bits, 100% de TRABAJO

Después de ejecutar el comando, tienes que ir al administrador de tareas para borrar el explorer.exe y luego reabrir la solicitud de nuevo.

Para abrir la solicitud, vaya a RUN entrar explorer.exe

Ahora está totalmente clara la información de conexión en la sesión.

44voto

CS-TA Puntos 61

Sé que esto es viejo, pero en caso de que alguien lo lea en el futuro....

La próxima vez que esto ocurra he encontrado la mejor manera de deshacerse de las credenciales es abrir una línea de comando elevada y teclear:

net use \\server\share /delete

y luego escribe:

klist purge

Lo intenté con ambos comandos individualmente y no trabajan solos. Primero tienes que quitar la conexión si existe. Luego quitar el ticket de autenticación de Kerberos de la máquina. Tuve un incidente como el suyo en el que la conexión ya no existía pero el ticket de Kerberos no había expirado todavía, así que cuando volví a entrar y no había salido de la máquina usaría mis credenciales previamente introducidas. Al purgar el billete, me pidió las credenciales de nuevo.

13voto

Goez Puntos 1170

Vaya al panel de control -> Cuentas de usuario -> haga clic en su nombre -> a la izquierda haga clic en "credenciales" (o administre sus credenciales). Todas las credenciales de la red utilizadas estarán allí.

9voto

Greenstone Walker Puntos 521

Lo siguiente debería hacer lo que usted quiere.

C:\> net use \\server\share /d
C:\> net use \\server\ipc$ /d

3voto

devin Puntos 1614

He conseguido acceder a la parte usando el nombre de dominio en lugar de la IP, pero tengo curiosidad.

Esto es un signo de un mal caché en el lado del cliente y normalmente se relaciona con los netbios.

Intente reiniciar la siguiente lista de servicios y, si es necesario, mate al explorador, inicie el gestor de tareas e inícielo de nuevo mediante el archivo del gestor de tareas->entrada de ejecución, ya que el explorador también puede estar almacenando en caché cosas de esos servicios.

No sé exactamente cuál es el servicio que falla de su lado, así que puede probar esta lista, de una en una para ver si funciona:

-TCP/IP NetBIOS Helper (can even be off if you add your machines to the DNS/host file)
-Workstation    <---   TRY THIS ONE FIRST
-computer browse
-net logon
-rpc service

si funciona, informar de lo que fue el servicio, para que otros puedan intentarlo directamente

Buena suerte.

EnMiMaquinaFunciona.com

EnMiMaquinaFunciona es una comunidad de administradores de sistemas en la que puedes resolver tus problemas y dudas.
Puedes consultar las preguntas de otros sysadmin, hacer tus propias preguntas o resolver las de los demás.

Powered by: